1. ae6dx's Avatar
    I jailbroke 4.1 with Limer1ain. When 4.2 comes out will I have to rejailbreak? Will Limer1ain support 4.2? I see no mention of it on Limer1ain website. I have seen no clear explanation for how to upgrade from 4.1 to 4.2 if you are jailbroken under 4.1.
    11-11-2010 02:54 PM
  2. farbod21's Avatar
    Yes you will always have to re-jailbreak. There is nothing that can be done about that. A jailbreak goes on top of firmware, its impossible to change what is underneath while keeping the jailbreak. You can read more here:
    Farbod's Jailbreak FAQ
    11-11-2010 02:58 PM
  3. ae6dx's Avatar
    Understood. Will Limera1n be able to Jailbreak 4.2?
    11-11-2010 03:41 PM
  4. jackie treehorn's Avatar
    Yes the exploit used is a low level bootrom exploit, meaning that no matter what apple does software side it is pwned for the life of the device. Only will a hardware revision patch the exploit.
    11-11-2010 04:23 PM
  5. farbod21's Avatar
    Your device will always be able to be jailbroken. The question is will it be tethered...
    11-11-2010 04:35 PM
  6. ae6dx's Avatar
    In your upgrade FAQ it says

    4. Restore to a fresh iOS version using Shift (Option) + Restore on iTunes
    I just want to clarify. In this step I would select the iOS 4.1 file located at ~/Library/iTunes/iPhone Software Updates ?

    If I deleted it is there a way to get the 4.1 file back? Or can I just simply restore to 4.2 bu doing a regular restore?
    11-11-2010 11:06 PM
  7. Cleveland's Avatar
    Understood. Will Limera1n be able to Jailbreak 4.2?
    According to Saurik (Cydia) anyone wanting to upgrade to 4.2 should hold off, it's being said that only tethered jailbreaks are possible with the i4 and 4.2
    11-13-2010 03:33 PM
  8. Ipheuria's Avatar
    Also you can always get OEM firmware at iClarified.
    11-13-2010 06:15 PM
  9. farbod21's Avatar
    According to Saurik (Cydia) anyone wanting to upgrade to 4.2 should hold off, it's being said that only tethered jailbreaks are possible with the i4 and 4.2
    Not true, you should hold off because cydia doesnt work yet. 4.2b3 is already untethered and 4.2 final wont take much work to get there as well...
    11-13-2010 06:18 PM
LINK TO POST COPIED TO CLIPBOARD