1. ritupa's Avatar
    Dear Friends,

    I bought an iphone 4g, told it was unlocked and i connected it itunes, its not taking sim. service provider said its locked.

    so tried to jail break phone, it went to restore, i selected restore and update in itunes.

    after that phone is not working, its giving languages to slide.

    dont know what wrong with it, cant access phone, only thing i can access is emergency call and that to sim is not recognised.

    kindly help me.

    Regards,
    Ritu
    05-30-2011 01:08 PM
  2. Ham Solo's Avatar
    I can't help you personally, but hang tight, I'm sure someone will come along and provide a solution. The knowledge and resourcefulness in this place is incredible!
    05-30-2011 07:44 PM
  3. alex.shimp's Avatar
    Sounds like it was actually "NOT" carrier unlocked
    05-30-2011 08:13 PM
  4. anaphora68's Avatar
    Need more info, like are you trying to activate the phone, in the US, on a carrier other than AT&T?

    First - you got taken. You were definitely sold a phone that was not carrier unlocked. I would suggest posting your question in the Jailbreak forum. Someone will be able to give you the instructions you need to carrier unlock the phone.

    Second - Good luck. Buying form a third party is always a risky endeavor.
    05-31-2011 07:15 AM
  5. kevin smith 619's Avatar
    its not your phone its your sim problem
    05-31-2011 07:15 AM
  6. itsalexaye's Avatar
    I agree with the last poster. it sounds like a SIM problem not an iPhone problem.
    05-31-2011 08:21 AM
  7. Massie's Avatar
    The answer is in the first line of the first post: "I bought an iphone 4g, told it was unlocked and i connected it itunes, its not taking sim. service provider said its locked."

    Basically, you can't use it unless you want to use an authorized service provider. Sorry.
    05-31-2011 08:55 AM
  8. aberrant.chicken's Avatar
    When you bought it... did you ask if it was carrier unlocked, software unlocked, or hardware unlocked?

    carrier unlocked means it's unlocked by the carrier in other words it's a permanent unlock, software unlock is using ultrasnow, and hardware unlock is done by using this sim chip (gevey sim).

    I have bought an iphone 4 that is ultrasnow unlocked and when I first got it, there was no way the sim was taken either... i had to reinstall ultrasnow and it worked... but to be able to achieve this, your baseband (modem firmware on your phone under settings>general>about) must be 01.59.00. If this is the case of the phone... I do hope you restored your phone using a custom ipsw that will not upgrade that baseband. If you did... then to be able to use the phone now you must either unlock it by carrier or buy a gevey sim.

    i would suggest you to first check with the seller to see how was the phone unlocked and check your sim on another device to see if there is any problems with the sim.
    05-31-2011 10:46 AM
  9. jsntrenkler's Avatar
    Sounds like you got scammed. Bummer.
    06-02-2011 12:34 AM
  10. hpcomputergeek's Avatar
    Return the iPhone from where ever you got it and get a new iPhone 4.
    06-02-2011 09:30 AM
  11. KevinMartin's Avatar
    I think it may be Sim or may be your service provider problem..I think unlocking is not a good option for iPhone because sometime it not performing well.
    09-11-2012 05:08 AM
  12. ColoradoiPhone's Avatar
    The phone may very well work, but as far as it being factory unlocked that is a no. When it's factory unlocked and you connect it to iTunes it will say, "congrats you phone is unlocked" (as in you spent a ton of money with your carrier to do so). If that didn't happen then it was jail broke. You will have to set the phone up as a new phone once you re-jail break the phone, so it may give you those options. It won't actually take the service until the phone is set up. If you are using T-Mobile then use straight talk they use ATT towers and the sim drops right in. Hope this helps a little.
    09-11-2012 05:43 PM
LINK TO POST COPIED TO CLIPBOARD