Do Not Disturb function in 15.1 not working

TGB77

Well-known member
Dec 6, 2018
49
0
0
Visit site
So I am using the new 15.1 IOS in which Do Not Disturb is buried within something called Focus. As it was unclear if the 'turn on automatically' is superseded by whether or not the Do Not Disturb switch is turned on or green, I decided to conduct some tests.
1) with DND on (or green) and with DND off (or white)
2) calling during the time range selected in 'turn on automatically' and calling outside the time range selected in 'turn on automatically'.
Thus there are four different scenarios. In each of the four, the phone still rings when calling from another number (and this number hasn't been entered as an "always allow" number).

Is there a fix to this?
 

SwitchBeach

Well-known member
Sep 2, 2013
2,968
6
38
Visit site
I'm not seeing this behavior when my phone is in Do Not Disturb mode (which I have automatically enabled during certain hours).

Is your phone locked when you are seeing this?
 

EdwinG

Ambassador
Mar 10, 2012
4,153
697
113
Visit site
I'm not seeing this behavior when my phone is in Do Not Disturb mode (which I have automatically enabled during certain hours).

Is your phone locked when you are seeing this?

This, and have a look at the following People notifications setting in your Do Not Disturb Focus:
9a04f242b25e7775bc6117d21f42c6ed.jpg
 

TGB77

Well-known member
Dec 6, 2018
49
0
0
Visit site
I'm not seeing this behavior when my phone is in Do Not Disturb mode (which I have automatically enabled during certain hours).

Is your phone locked when you are seeing this?

Not sure. That doubles the # of scenarios I have to check from four to eight.

What puzzles me is why Apple does not make this a little more straightforward. Why should the only way to determine if it works be to test it in all possible scenarios?
 

TGB77

Well-known member
Dec 6, 2018
49
0
0
Visit site
I'm not seeing this behavior when my phone is in Do Not Disturb mode (which I have automatically enabled during certain hours).

Is your phone locked when you are seeing this?

I have tried it with the phone in both the locked and the unlocked modes. In all eight scenarios, the phone rings.
 

doogald

Trusted Member
Oct 23, 2012
2,771
109
63
Visit site
The phone # I am calling from is not listed there.

Is the number listed at all in one of your contact records? Calls from people and favorites allows calls from all numbers associated with a contact. So if my wife calls from either her cell phone or our home landline, the call will go through when DND is turned on.
 

TGB77

Well-known member
Dec 6, 2018
49
0
0
Visit site
Is the number listed at all in one of your contact records? Calls from people and favorites allows calls from all numbers associated with a contact. So if my wife calls from either her cell phone or our home landline, the call will go through when DND is turned on.

The # is listed in my contacts. But it is not among those listed as "allow calls from" with respect to DND.
 

TGB77

Well-known member
Dec 6, 2018
49
0
0
Visit site
Do you have "Contacts" or "Favorites" enabled for DND?
No.
I did talk with Apple tech support.
They said if DND is on, the little moon will display in the upper right and if the moon is displayed, the phone should not ring. They added it can turn on by the user manually toggling DND from off (white) to on (green) or if it is in the white off position, and the start time under 'TURN ON AUTOMATICALLY' passes (e.g. if the time range is 10PM to 7AM and the clock changes from 9:59 PM to 10PM).

But my phone still rings with the DND green and the moon displayed.
 

TGB77

Well-known member
Dec 6, 2018
49
0
0
Visit site
Call AppleCare and see if they can sort this out for you. I know that it is working fine for me.

I did talk with Apple tech support.
They said if DND is on, the little moon will display in the upper right and if the moon is displayed, the phone should not ring. They added it can turn on by the user manually toggling DND from off (white) to on (green) or if it is in the white off position, and the start time under 'TURN ON AUTOMATICALLY' passes (e.g. if the time range is 10PM to 7AM and the clock changes from 9:59 PM to 10PM).

But my phone still rings with the DND green and the moon displayed.
 

TGB77

Well-known member
Dec 6, 2018
49
0
0
Visit site
Update.
I tried another experiment. I removed all people under 'ALLOWED NOTIFICATIONS' and turned on (or green) 'do not disturb'. I called the iPhone from my home phone and it rang. Then I tried calling it again, but entered *67 before dialing my 10 digit cell phone #. And this time it did not ring. So somehow my iPhone is recognizing my home land line as an 'always accept' number. But how is it doing this? I looked up my land line in my contacts and it doesn't have it marked as emergency contact or anything like that.

So DND is technically working, but somehow my land line is exempt from DND.
 

EdwinG

Ambassador
Mar 10, 2012
4,153
697
113
Visit site
Update.
I tried another experiment. I removed all people under 'ALLOWED NOTIFICATIONS' and turned on (or green) 'do not disturb'. I called the iPhone from my home phone and it rang. Then I tried calling it again, but entered *67 before dialing my 10 digit cell phone #. And this time it did not ring. So somehow my iPhone is recognizing my home land line as an 'always accept' number. But how is it doing this? I looked up my land line in my contacts and it doesn't have it marked as emergency contact or anything like that.

So DND is technically working, but somehow my land line is exempt from DND.

Open the Contacts app, and go to the top of the list. That should be your name with a subtitle of My Card.
Tap on it, and check if your home number is listed there.
 

Trending Posts

Members online

Forum statistics

Threads
260,756
Messages
1,768,164
Members
441,266
Latest member
vber