1. iMore Question's Avatar
    I would like to upgrade my iphone4 os from iOS 4 to iOS5.1.1

    First, I downloaded the IPSW file on web.

    Then I tried to update the iOS through itunes. It gave me error 3194. I searched the web and was told to add a line to the host file (me using windows 7).

    After this, I tried again. This time no error 3194 but another error - 3004 comes up.

    May I know if anyone can tell how to solve the error 3004 issue (given that i tried to google some solutions to 3004 but it did not work).

    Thanks all!
    12-24-2013 12:02 PM
  2. Chargehammer's Avatar
    Unless you have the SHSH blob saved for 5.1.1, you won't be able to go to that firmware. Apple stops signing older firmwares when a newer one is released. They haven't been signing 5.1.1 for quite some time now.

    You can use iFaith to see if you have the SHSH/apticket for the 5.1.1 firmware saved either locally or online with Cydia's server. If you do, you can use iFaith to restore to a "signed" ipsw by holding Shift/Restore.
    12-24-2013 01:13 PM
  3. Ericlee11's Avatar
    Thanks Chargehammer.

    Reading your message, does it mean that I need to create a SHSH blob myself with my iphone4 in order to restore the ipsw which I downloaded on web? Or I can search for a 5.1.1 SHSH blob on web through iFaith that I can make use of?

    I noted that if the phone is jailbroken, it can be "downgrade" to whatever lower iOS without SHSH blob? Would it be an alternative if there is no other way (other than jb the phone) to achieve my goal?

    Many thanks again for your time again.
    12-24-2013 02:05 PM
  4. Chargehammer's Avatar
    The SHSH blob/apticket is something that must be saved for the signed firmware at the time. Right now, the only firmware signed by Apple for the iPhone 4 is 7.0.4. So you if you use TinyUmbrella or iFaith, you can back up the SHSH blobs/apticket and use that when the tools are available.

    If you don't have the SHSH blobs/apticket for your specific iDevice for the firmware you're wanting to go to, then you simply can't go to it.

    Now if you find some way to do it, please share step-by-step on how you accomplished it. It would be very helpful info. To my knowledge, this is not possible unless you have the SHSH blobs/apticket somewhere. Please anyone feel free to correct me if I'm wrong.
    12-24-2013 02:55 PM

Similar Threads

  1. Replies: 140
    Last Post: 01-02-2014, 02:20 PM
  2. Lags on iOS 7?
    By Neil Espinili in forum iPad mini Series
    Replies: 5
    Last Post: 12-28-2013, 01:53 PM
  3. Facebook Profiles in iOS Contacts
    By spcurtis81 in forum iOS
    Replies: 1
    Last Post: 12-24-2013, 09:12 AM
  4. How do I switch from using native Mail to another client?
    By earthdude in forum Ask a Question
    Replies: 4
    Last Post: 12-24-2013, 08:36 AM
  5. Replies: 1
    Last Post: 12-24-2013, 08:15 AM