[Question] iPhone3,1 downgrade with FutureRestore+LibiPatcher error -38

salehosman2006

New member
May 23, 2022
2
0
1
Visit site
Hi, I am trying to downgrade my iPhone3,1 (GSM) to iOS 4.3.3 with blobs using FutureRestore+LibiPatcher, iPhone is in DFU mode.

But when I try to restore my iPhone, it gives me this output :

Version: <long hex value> - 157
Libipatcher : <long hex value> - 44
Odysseus Support : yes
[INFO] 32bit device detected
futurerestore init done
[Error] Error : failed to load shsh file <SHSHFile.shsh>
[Error] Fail code = -38
Failed with errorcode =-38

after typing this command :

./futurerestore_macos -t shsh.shsh --latest-baseband ipsw.ipsw

I use the same tool to downgrade an iPad 3 (Wi-Fi only) to iOS 5.1.1 with no problem and also an iPhone 4s to iOS 5.0.1, with no problem at all !

My blobs were stored on outlook mail, and I downloaded fresh ones from iFaith, same issue...

I also tried downgrading with Redsn0w (0.9.15b3), everything works but it can't update baseband and it fails any this step after 5 minutes. EDIT : Tried with iOS-OTA-Downgrader, it gave me an error: Your device is not supported for iPhone3,1.

Do you have any ideas on how to solve this issue? Thanks!