1. kjparfekt's Avatar
    All night when I click the software update button on the Apple Watch all I get is a spinning icon then an error asking if I would like to retry claiming I'm not connected to the Internet. I get the same message while on wifi or cellular. Tried closing the app and restarting my phone but no luck.

    I'm guessing it could be days/weeks before the update rather than hours like I was hoping.
    09-16-2015 11:51 PM
  2. Bigeric23's Avatar
    Have you restarted your watch?
    09-17-2015 08:12 AM
  3. kch50428's Avatar
    What made you think the update was delayed by hours?
    09-17-2015 08:13 AM
  4. kjparfekt's Avatar
    Yes I've tried restarting my watch. It's functioning fine otherwise. Here's a screen shot of the error.

    Thought the update might only be delayed hours because of the Apple executive that said it would be rolling out "shortly" which I know is an undefined term. Error when checking for update-imoreappimg_20150917_092255.jpg
    09-17-2015 09:22 AM
  5. That70sGAdawg's Avatar
    I'm getting that error too. it must be related to the hold on OS2...
    09-17-2015 02:43 PM
  6. 3spur's Avatar
    I'm getting that error as well, it's 3:42 on Thurs Sept 17
    09-17-2015 06:42 PM
  7. ericsmcdonald's Avatar
    What's weird for me is all day yesterday and this morning, while checking for OS updates, it would say 1.0.1 was the current OS. Starting this afternoon I've been receiving this error, too. Wonder what's going on.

    EDIT: as of 7:39 eastern, it's now back to saying 1.0.1 is the current version for me.
    Last edited by ericsmcdonald; 09-17-2015 at 07:40 PM. Reason: Update
    09-17-2015 07:28 PM
  8. Suggs68's Avatar
    I was actually more excited for Watch OS2 than I was for iOS 9, so I hope they at least give us some kind of update of when we can expect it soon. Def rather have it bug free so happy they pulled it, but have never seen that happen before with them for an announced, dated update.
    09-17-2015 08:39 PM
  9. AmazingGraceTx's Avatar
    I'm getting the same error.
    09-17-2015 08:45 PM
  10. kjparfekt's Avatar
    I'm back to getting the "software is up to date" message. Error when checking for update-imoreappimg_20150917_213923.jpg
    09-17-2015 09:39 PM
  11. curve1967's Avatar
    Getting the same error on wifi
    Error when checking for update-imoreappimg_20150917_214758.jpg

    And on cellular data
    Error when checking for update-imoreappimg_20150917_214812.jpg
    09-17-2015 09:48 PM
  12. ericsmcdonald's Avatar
    I'm not sure what's up. Maybe there's something timing out on the phone? I'm now back to that error. However, if I reboot the phone (even simply turning off/on) then I get the regular "1.0.1 is the current version" message.
    09-18-2015 11:28 AM
  13. lackster2's Avatar
    Yea, some prognosticators are predicting about a weeks delay, although no one really knows until Apple releases the update. I'm sure iMore will keep us informed and it will be a headline item when it occurs.
    09-21-2015 04:00 AM

Similar Threads

  1. iOS 9 update stalled at iTunes, what can I do?
    By iMore Question in forum iOS 9
    Replies: 3
    Last Post: 09-18-2015, 05:53 PM
  2. What happened to contact photos for iphone 6 with IOS 9?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 09-17-2015, 02:15 AM
  3. Replies: 8
    Last Post: 09-16-2015, 10:28 PM
LINK TO POST COPIED TO CLIPBOARD