1. ke6mtf's Avatar
    I am a long time iOS user. I love to use autofill. But recently it started fighting me. All my info is correct, but for email address it insists on using my Facebook address. I see no reason to use it since I prefer my others. I adjusted my address book so it is listed last hoping that would fix it. But it still uses it!! Does anyone know of a fix or workaround for it?

    I'm running 6.0.1 on my iPad and 6.0.2 on my Iphone 5 and both are doing the same. Just to be clear I'm not jailbroken.
    01-05-2013 03:16 AM
  2. iNotes4You's Avatar
    I am a short time user of iOS. Just 1 year. Maybe I am wrong but try set Use contact info OFF and clear all Passwords in Settings - Safari - AutoFill Autofill wrong info, Facebook address??-imageuploadedbytapatalk1357544146.841760.jpg
    01-07-2013 02:36 AM
  3. ke6mtf's Avatar
    I want to use autofill, so unless I am not understanding what you mean then that isn't the solution I'm looking for. I want to use it and it works well for me. It just it insists on using a different email address then the one I want it to.....
    01-07-2013 02:44 AM
  4. Retconaddict's Avatar
    Well that's what he's suggesting. To clear the autopilot suggestions and input them again in whatever websites you need them. It should do it automatically again after that.
    01-07-2013 06:04 AM
  5. ke6mtf's Avatar
    Not sure if I am using the wrong terms or just worded it poorly to convey the problem. Saving data to fill a form on a website I "think" is called something else. I say that because when it is done, you do nothing but the data is filled in. What I am talking about is the "autofill", the button. Generally used when setting up an account on a new website. For this to work it has to be connected with a contact card that has the info in it. When on the website instead of typing in all the data manually (name, address, phone number, and email) you press the "autofill" button that then does it for you. It used to work great. But after iOS added Facebook login it only wants to use my Facebook email address. I have five email addresses. I have edited and rearranged the contact info, but the Facebook one seems to be the one "autofill" wants to use. I don't mind it being in my contact info, I just don't want it to be the "autofill" default address. I personally don't know why anyone would want to use a Facebook address for any website other than Facebook, but my iOS devices seem to disagree.....
    01-08-2013 02:51 AM
  6. Lisa Berger Collins's Avatar
    Did you ever figure this out?? I am having the same problem (auto fill defaulting to Facebook email)
    07-16-2013 11:41 PM
  7. csd's Avatar
    I am having the same problem. Really frustrating. Only solution I've found is to unlink my FB account from my Contact record, but that causes other issues.
    08-03-2013 11:50 PM
  8. ptowndave's Avatar
    Having same issue any solutions?

    I created a new contact with the info I want to use and in the autofill settings used the new contact as the one to choose
    Last edited by ptowndave; 10-11-2013 at 12:00 AM.
    10-09-2013 07:04 PM
  9. ke6mtf's Avatar
    No luck yet, still quite annoying. Seems the best idea is the new contact idea, though I find it insane that or disconnecting Facebook are the two best options. Am I missing something or are those truly the only options???
    11-03-2013 01:38 AM
  10. brent_noorda's Avatar
    This is the solution that has worked for me. 1) In settings -> safari -> passwords & autofill I change "My Info" to be some completely incorrect contact. 2) back in safari I fill in the login item with my correct email address, 3) go back to settings -> safari -> passwords & autofill and change "My Info" back to my correct contact. After all this the problem seems OK (until I reinstall facebook for some reason and the problem shows up again)
    12-07-2013 11:36 PM
  11. a316403's Avatar
    This is an old thread but a new issue for me. I could not even edit out my FB email using my iPad settings because it was grayed out and non-editable. So, I went to my FB page, general settings, email, edit. Then UNCHECK "use your Facebook email". Got my auto fill back! Damn Facebook defaults.
    Last edited by a316403; 10-17-2014 at 08:51 PM.
    10-17-2014 07:42 PM

Similar Threads

  1. Facebook location all wrong
    By mpagano37 in forum Twitter
    Replies: 0
    Last Post: 03-04-2012, 04:54 PM
  2. Facebook: wrong avatar
    By Judson50 in forum iPhone Apps & Games
    Replies: 3
    Last Post: 02-03-2012, 05:09 PM
  3. Replies: 0
    Last Post: 10-02-2011, 07:51 PM
  4. WHAT is wrong with Facebook?!
    By MECM in forum Twitter
    Replies: 10
    Last Post: 04-29-2011, 07:34 AM
  5. FaceBook on iPhone 3GS: infos update problems
    By Macfreak#IM in forum Twitter
    Replies: 1
    Last Post: 07-15-2010, 03:08 PM