1. Flames5123's Avatar
    So I currently (had) have a jailbroken 4.3.1 iPhone 4 GSM. Now it is just a brick.... I wanted to restore to the new 4.3.3. It keeps giving me the error 1031 and going straight into recovery. I have tinyumbrella and have saved my shsh blobs. I have tried to fix recovery and exit recovery too. Also, I have entered DFU mode (black screen instead of plugin to itunes logo) to try to restore and that didn't help either. I am pretty computer savvy, but somehow these kind of things always happen to me and like me only.... Please help!
    06-08-2011 04:16 AM
  2. Flames5123's Avatar
    I found help. post here if you need my help with the same error
    06-08-2011 04:51 AM
  3. lowkey#IM's Avatar
    Can u pls post yr steps or link here? Tks for sharing
    06-08-2011 07:57 AM
  4. Ipheuria's Avatar
    If you ask me your problem is that you used Tiny Umbrella so that your hosts file has been edited. So what I would say would have been the easy way to recover is search for my username on here and threads I created look for the thread "What to do if you can't upgrade with iTunes..."

    1. Edit your hosts file or use Tiny Umbrella option(instructions in my thread)
    2. Connect your iPhone either in DFU mode or regular mode
    3. hit upgrade(regular mode) or restore(DFU mode)
    06-10-2011 08:01 AM
LINK TO POST COPIED TO CLIPBOARD