1. vinniet's Avatar
    I can not figure out this problem I have. I was running 2.1 on 2G iPhone which was Jailbroken and unlocked. I upgraded my iTunes to 8.0.2. I have a ATT SIM card that is not activated and also a TMO SIM card from my phone.

    I did a backup and upgraded to 2.2 and did not do a restore. I then ran QuickPWN and selected Cynia and Unlock as the options. It all seems to work fine when I have the ATT card in. BUT when I insert the TMO it says "Different SIM detected - Please connect to iTunes"

    When I connect to iTunes (8.0.1 & 8.0.2) it says "The SIM card inserted in this iPhone does not appear to be supported"

    I have tried to restore and Jailbreak again but the iPhone does not work with the TMO card in.

    HELP! Thanks!
    Last edited by vinniet; 11-29-2008 at 12:59 PM.
    11-29-2008 12:46 PM
  2. vinniet's Avatar
    I have fixed my problem. With lots of trial and error I figured it out. It turns out that I had to do a restore and Jailbreak with the TMO card in. After Jailbreaking the phone it worked perfectly with either the TMO or ATT card.

    I guess not many people had this problem since they stick with just one SIM card at all time.
    11-29-2008 09:29 PM
LINK TO POST COPIED TO CLIPBOARD