1. Jellotime91's Avatar
    First problem already..

    I don't know if anyone else has had this problem on Windows 7, but when I restored my iPhone 4 from backup and went into the applications tab, the only app that would sync is "castle".. which is awesome, but I'd rather have more than one app..

    When I drag an app from the list onto the "screen", it does not show up, but it can oddly make folders out of nothing....

    Most of the apps I can just re-download on the device, but the paid apps I can not.

    Help please?
    07-30-2010 09:53 PM
  2. chobbs1's Avatar
    Let us know the steps you've already taken. Did you go to the apps page and select all the apps that you want to sync? Ya know stuff like that. I am sure these are remedial steps to you but it will get everyone on the same page.
    Last edited by chobbs1; 07-31-2010 at 01:03 AM.
    07-30-2010 10:28 PM
  3. Alli's Avatar
    The few people I know who restored from backup had problems. I went ahead and started brand new when I got my iPhone 4. Much easier.
    07-31-2010 12:54 AM
  4. chobbs1's Avatar
    I restored from a back up and had no problems. I did, however, end up restoring as new a few weeks later because I felt the phone was not running as smooth as it should.
    07-31-2010 01:05 AM
  5. fresh1's Avatar
    Let us know the steps you've already taken. Did you go to the apps page and select all the apps that you want to sync? Ya know stuff like that. I am sure these are remedial steps to you but it will get everyone on the same page.
    Yea, did you make sure all the apps you want to sync are checked off ( while iphone is connected to itunes )??

    Are all your apps showing up in itunes on your cpu ( under apps tab)??

    Like Chobbs said what steps have you already tried ??



    Fresh1
    07-31-2010 01:48 AM
  6. Jellotime91's Avatar
    As I restored from backup all of the apps I wanted were already checked, but only one of the apps would sync over. I did try unchecking all of them and then rechecking... No luck.

    I have always restored from backup and never had a problem, so I don't want to. I really like having my notes, text messages, etc from all the way back in 2008...

    I've restored from a newer backup and tried again, still no luck with anything other than Castle.

    UPDATE:

    I restored it as new and guess what, no apps will sync unless I downloaded them on the iPhone 4 previously... So, all of my paid apps are lost.

    This is great. Thanks Apple.
    Last edited by Jellotime91; 07-31-2010 at 09:50 AM.
    07-31-2010 08:19 AM
  7. Alli's Avatar
    You sure you logged into itunes with the same account? My son had this problem when he updated to the 3GS...he discovered that at some point he'd created two itunes accounts, and was using the wrong one to try to redownload his paid apps.
    07-31-2010 09:58 AM
  8. chobbs1's Avatar
    I guessing that iTunes thinks that it is a second phone for some reason. Did you change your number? Also, from what I understand, you'll be able to redownload those paid apps from iTunes for free as long as you do it from the same iTunes account.
    07-31-2010 09:59 AM
  9. Jellotime91's Avatar
    Hey guys, found out the problem. I just recently reinstalled windows, and iTunes saw in the xml file that all my apps were there, but it didn't know their exact location. So I manually re-added the apps to iTunes by going to "Add Folder To Library" and now it works perfectly.

    Thanks for your help anyway.

    And chobbs, I did notice also that my phone runs faster when it's not restored from backup.. When I activated it yesterday I was kind of underwhelmed by performance but I didn't think it was unusual. It's definitely better now!

    Sidenote: iBooks still takes a hilariously long time to open compared to other apps.. :P
    07-31-2010 10:29 AM
  10. cacadong's Avatar
    Thanks all, I also have the problem and solve it now
    08-03-2010 05:14 AM
LINK TO POST COPIED TO CLIPBOARD