1. Rene Ritchie's Avatar
    Weird. My corp VPN, set up on the iPhone, works perfectly when I'm connected via WiFi. If I switch to 3G (on Rogers), it's dead to the world. Tried it on 2 iPhones, and on EDGE as well (also dead).

    Anyone have any ideas?
    11-11-2008 08:07 PM
  2. hermdog's Avatar
    Is that by design maybe?
    11-11-2008 08:38 PM
  3. Rene Ritchie's Avatar
    You mean on Apple's end? Hmm... Never thought of that.

    Hope not, though, because it would destroy tons of functionality. VPN over 3G is just essential to so many things that require secure connections.
    11-11-2008 11:10 PM
  4. hermdog's Avatar
    Well, I went to the horses mouth. This article iPhone and iPod touch: Setting up VPN states the following "iPhone or iPod touch devices with iPhone 2.0 software or later can connect to VPNs that use the L2TP, PPTP or Cisco IPSec VPN protocols. VPN works over both Wi-Fi and cellular data network connections."

    So you are correct it should work.
    11-12-2008 07:14 AM
  5. hermdog's Avatar
    Rene, I have confirmed that it does not work over 3G. Haven't been in an EDGE area to try, but I would think it would fail the same. I'm on AT&T network. So are we looking at a bug here?
    11-12-2008 07:27 AM
  6. Rene Ritchie's Avatar
    We may be! Time to do some digging...
    11-12-2008 12:32 PM
  7. jamesus's Avatar
    Rene, I have confirmed that it does not work over 3G. Haven't been in an EDGE area to try, but I would think it would fail the same. I'm on AT&T network. So are we looking at a bug here?
    You can try by switching off the 3G toggle, that will mandate you use EDGE.
    11-12-2008 12:58 PM
  8. hermdog's Avatar
    Rene

    VPN has been fixed in 2.2. Works over 3G and Edge. Yipeee!!!
    11-24-2008 06:32 PM
  9. kataleen's Avatar
    Same problem here. Never could connect my company's VPN through 3G. Only WiFi. I am currently running iPhone 3.0 and it's the same.
    Any thoughts?

    Tx
    06-23-2009 05:09 PM
  10. HoozYerDdy's Avatar


    Based on this thread, looks like it was fixed in 2.2 but broken again in 3.0

    This problem makes VPN useless to me. at home I may as well go to my laptop, but I need this most when I am away from all of my gear to get connected into work.

    hopefully this will be fixed soon
    07-09-2009 04:17 PM
  11. flyingember's Avatar
    is your vpn device set to limit incoming connections based on its source? what about NAT? does is allow connections from behind a nat device?
    07-10-2009 12:13 PM
  12. HoozYerDdy's Avatar
    is your vpn device set to limit incoming connections based on its source? what about NAT? does is allow connections from behind a nat device?

    Works over wireless, which is typically NAT'd and I can connect and route just fine.

    3G connects just fine, but does not route. Im not a network expert, but I would guess its something to do with AT&T's data network that is causing this to fail or some component of the 3.0 OS that is breaking down since it was 'fixed' at one point in the 2.2 OS.
    07-10-2009 12:26 PM
  13. yunshou's Avatar
    I have the same issue with my 3GS Iphone, no problem to VPN and connect to the company's server using wifi, but no luck with 3G network, tried the Network Ping LT , Jaadu Romote Desktop and VNC LT, I don't think it is the application problem, might be something related to the IPhone software or
    the 3G carrier.
    I am using 3G network from Rogers in Canada.
    07-21-2009 06:04 PM
  14. miked#IM's Avatar
    (bump)

    My understanding, at least with AT&T, is that there are two data plans: the regular $30 one, and the $45 "business" one that permits VPN connections over iPhone. If you go to the AT&T web site and log onto your account, you should be able to see that you can upgrade to the $45 version.

    In any case, Jaadu VNC works great for me . . . .
    08-30-2009 01:23 AM
  15. RMCSteve's Avatar
    This problem can be fixed by enabling NAT transversal over IPSec. If your router doesn't support it, you are out of luck. I had the exact same problem with a Cisco Pix. Good luck.
    10-06-2009 09:15 PM
  16. Justin251's Avatar
    Sign into your PIX/ASA using ASDM. Go into configuration, Remote Access VPN, Network (Client) Access, IPsec Connection Profiles, IKE Parameters. There should be a check box "Enable IPsec over NAT-T". save your config & you are good to go!
    02-16-2010 12:52 PM
  17. Castorpoluks's Avatar
    Hello my friend. I suggest you to install Open VPN and all will work perfectly well. 3G/Edge or any other option. Software is open source.
    Cheers
    06-06-2010 12:46 PM
  18. 4r4nd0mninj4's Avatar
    I was told by a Rogers rep that VPN will not work over their 3G network. He could not tell me why. I can confirm that it does indeed not work.
    06-29-2010 09:29 PM
  19. jamesus's Avatar
    For AT&T users, LogMeIn works like a dream. Definitely worth the $30 price tag...
    06-29-2010 10:55 PM
  20. heilala's Avatar
    do you set up right?

    1. Open Settings.
    2. Open General.
    3. Open Network.
    4. Open VPN.
    5. Open Add VPN Configuration.
    6. Choose PPTP.
    7. Under Description, enter Trueshield.
    8. Under Server, enter vpn ip
    9. Under Account, enter your username.
    10. Leave RSA SecurID unmarked (OFF).
    11. Under Password enter your password.
    12. Under Encryption Level choose Maximum.
    13. Under Send All Traffic make sure ON is selected.
    14. Leave Proxy marked as OFF.
    15. Press Save.
    16. Make sure Trueshield is ticked, otherwise just press it to tick it.
    17. Under VPN slide from OFF to ON.
    18. Wait for the icon VPN to appear in the top status bar.
    03-16-2012 03:18 AM
LINK TO POST COPIED TO CLIPBOARD