1. haxrnick's Avatar
    The past week my gf and I had no problem using iMessage back and forth. Last night I did I restore on my phone and started from scratch. Now when we iMessage it shows coming from my email and not my phone number anymore so she has two separate texts from me. Did I miss a setting on my phone after the restore? Any help will be greatly appreciated.
    06-14-2011 12:11 PM
  2. chadderbox's Avatar
    Have you tried turning it off and back on again?
    06-14-2011 03:32 PM
  3. haxrnick's Avatar
    Have you tried turning it off and back on again?
    Yes, and it worked temporarily then went back to the two different texts. I guess it could just be part of it being a beta and I understand that. It doesn't bother me at all since it's just on her phone but was just checking if anyone else had this happen.
    06-14-2011 04:57 PM
  4. Ipheuria's Avatar
    In the settings where you can an email is there anything there? Did you try rebooting the phone?
    06-14-2011 05:41 PM
  5. lilmoe's Avatar
    If you are jailbroken, reboot tethered with redsn0w. It worked for me!
    06-20-2011 10:07 AM
  6. maaatter's Avatar
    In Setting - Messages - Receive At - Caller ID - do you have your email or number selected?
    06-20-2011 12:34 PM
  7. haxrnick's Avatar
    I just downgraded back to 4.3.3 and installed as new then upgraded to 5 and everything seems to have worked. Not sure what happened but if anyone else has the problem that's how I fixed mine.
    06-20-2011 06:16 PM
LINK TO POST COPIED TO CLIPBOARD