Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 1 of 1
  1. Thread AuthorThread Author   #1  
    sahmad88's Avatar
    iPhone Nanite

    8 Posts
    Global Posts
    136 Global Posts

    Default Anyone tried renting movie directly to phone on 3.0? Mine failed.

    First, thanks to everyone for all of you great advice. I have read the forums for a while. I have a new iPhone that I upgraded today to 3.0. I tried renting Taken and having it download directly to the phone. It seemed to work fine, didn't take any longer than it does to my PC. It finished downloading, then began "processing" the file. That is when it failed. I get a "Download failed. Tap to retry." message. I keep tapping, but no love. I tried calling iPhone support, but they said I need to talk to iTunes support and they are closed. So I thought I would post here. I have plenty of room on my phone - over 12GB of space. Has anyone else had problems with this or does anyone else know how I might fix it? Thanks again.

Posting Permissions