Weird calendar issue...

Annie_M

Moderator
Mar 2, 2016
22,257
826
113
Visit site
This is complicated, and hopefully, I will describe the issue clearly!

My employer uses Gmail's business suite, and two co-workers have shared their calendars with me, so that I can add appointments, etc.

I use Apple's stock calendar app on my iPhone and iPad. I can see both coworkers' calendars on each device, and until sometime in the last few months, I've never had any issues.

Then I started receiving calendar invites for my coworkers' calendars in my iPhone & iPad calendar inbox. If I delete them, they disappear completely, and my coworkers will miss them. It's really no big deal, but it bugs me because they don't deal with their invites in a timely fashion, and it always looks like I've got items in my inbox. I don't know if the issue is an Apple calendar issue or a Google calendar issue.

I've tried calling my employer's help desk, and the person I spoke with has an Android. He suggested that I come in, which I will do if I can't figure it out. I have also looked around on the internet, and, tried looking in Settings for something obvious, which of course, there isn't anything obvious.

So here I am!!!
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,876
669
113
Visit site
@Annie You’d think the following would only apply to the people sharing their calendars, but see if it’ll work for you

Turn off notifications for shared calendars
When someone modifies a calendar you’re sharing, you’re notified of the change. You can turn off notifications, if you don’t want to receive them.
Go to Settings > Notifications > Calendar > Customize Notifications.
Turn off Shared Calendar Changes.

Source: https://support.apple.com/guide/iphone/share-icloud-calendars-iph7613c4fb/ios
 

Annie_M

Moderator
Mar 2, 2016
22,257
826
113
Visit site
@Annie You’d think the following would only apply to the people sharing their calendars, but see if it’ll work for you

Turn off notifications for shared calendars
When someone modifies a calendar you’re sharing, you’re notified of the change. You can turn off notifications, if you don’t want to receive them.
Go to Settings > Notifications > Calendar > Customize Notifications.
Turn off Shared Calendar Changes.

Source: https://support.apple.com/guide/iphone/share-icloud-calendars-iph7613c4fb/ios

Thanks! I’ll give that a whirl!
 

Trending Posts

Members online

Forum statistics

Threads
260,760
Messages
1,768,185
Members
441,265
Latest member
vber