No More Scrolling Possible on iMore Pages & Subpages

gnirkatto

Well-known member
Nov 4, 2017
570
6
18
Visit site
I don't know how to make meaningful screenshots/videos of something that just refuses to work - I also don't have time to learn new apps like loom (or whatever that's called) just to report a bug.

So maybe someone is interested anyway:

Very often, the iMore home page and/or its subpages refuse to scroll. You scroll down and basically nothing happens. Refresh of the page doesn't help. The page has to be closed completely, then reopened and then it works again - for a while.
To clarify, the respective page is NOT frozen when this happens! it moves slightly when trying to scroll, but it doesn't scroll. All other sites work flawlessly.

This problem became obvious since the cookie confirmation/rejection popups became incredibly annoying, by showing always and every time when an iMore page or subpage gets opened.

This is outrageous. I usually had the iMore main page open all the time on my Mac, and was only requested to set the cookies once, during the initial opening. Now I have to do that always, again and again, whenever opening a (sub)page through a link. And this goes on and on, even though I still keep the iMore site open.

I don't know if this cookie madness has anything to do with the site refusing to scroll, but suspect that it does. Both began to occur at the same time.

It's so annoying that I'm seriously considering to no longer use the site, after all these years....

Mac OS 13.2.1
Safari 16.3
 

gnirkatto

Well-known member
Nov 4, 2017
570
6
18
Visit site
Just to clarify, are you referring to the Forum site or the iMore "Blog" Site?

the iMore main page, and its subpages. Intermittently, not reproducible (I have not yet identified a particular scenario that makes the problem occur). So yes, I guess this is what you call "Blog Site".
Not the Forum.
 

Bla1ze

Staff member
Nov 7, 2014
300
130
43
Visit site
I asked because I want to notify @Bla1ze!

I've done some quick testing with Safari and can't seem to reproduce anything of that nature. For that matter, I don't even get asked about Cookie consent or anything. I'll investigate a bit more, and see if I can come up with anything. One quick fix, however, might be to simply clear your browser Cache and Cookies for iMore, which will trigger the Cookie Consent on next load and once set should stick and not ask you again.
 

Annie_M

Moderator
Mar 2, 2016
22,284
828
113
Visit site
I've done some quick testing with Safari and can't seem to reproduce anything of that nature. For that matter, I don't even get asked about Cookie consent or anything. I'll investigate a bit more, and see if I can come up with anything. One quick fix, however, might be to simply clear your browser Cache and Cookies for iMore, which will trigger the Cookie Consent on next load and once set should stick and not ask you again.

Thanks! FWIW, I didn't have any issues on Chrome!
 

gnirkatto

Well-known member
Nov 4, 2017
570
6
18
Visit site
maybe I should add that I never consent any cookies except those technically needed. On no site at all.
This is what I always did, since this madness started a few years ago.
Now, since a few days/weeks, cookie consent always pops up everywhere on the iMore site. Even if I read a blog post the cookie consent pops up (although already answered on the mother page), then going back to the page I came from, it pops up again.
I suspected this to be the reason for a page sometimes no longer working properly and refusing to scroll. But I'm not sure.
On the other hand, I did not want to allow all cookies just to try to make the site work.
I'm not going to start using Chrome or any other browser, I'm on a Mac and think that Apple related stuff should work on the Apple browser.

Will try to clear the cache (again, I think I did that already but am not sure) and try again.
 

gnirkatto

Well-known member
Nov 4, 2017
570
6
18
Visit site
FYI
The Cookie consent still pops up for every single page turn (even when returning to the previous page), which drives me mad.
The scrolling "freeze" has not reoccurred yet.
 

FFR

Well-known member
Nov 7, 2012
3,379
434
83
Visit site
If you have any content blockers or ad blockers might have to turn it off.


The constant cookie prompt happens to me as well on certain sites whenever I have the content blockers on and or a vpn.
 

gnirkatto

Well-known member
Nov 4, 2017
570
6
18
Visit site
I don't have any blockers installed, and no vpn.
Also, this wasn't that bad up until a couple of days or weeks ago.
Unfortunately I can't tell if it began with Ventura 13.2.1 or earlier
 

Wotchered

Well-known member
Oct 29, 2013
3,216
91
48
Visit site
Dunno ! After the Futura thing, the iMore forums app which is wot I’m writing this in, on my iPad gen 5, seems to be fine. The webpage says it’s discontinued, as of 18 July last. and there has been no new content since then.
 

EdwinG

Ambassador
Mar 10, 2012
4,168
702
113
Visit site
I don't have any blockers installed, and no vpn.
Also, this wasn't that bad up until a couple of days or weeks ago.
Unfortunately I can't tell if it began with Ventura 13.2.1 or earlier

Would you happen to have iCloud+ Private Relay​ enabled?
 

gnirkatto

Well-known member
Nov 4, 2017
570
6
18
Visit site
In Firefox, the cookie prompt apperars only once, at the beginning of a session - how it should be.
In Safari, always & everywhere.
This is ridiculous.
 

Latest posts

Trending Posts

Members online

Forum statistics

Threads
260,808
Messages
1,768,376
Members
441,268
Latest member
flickoo