Alarms not sounding consistently

sethclifford

Well-known member
Sep 25, 2006
55
2
0
about.me
I searched and didn't see anything related to this, so forgive me if I missed a post about this already.

I have noticed that my iPhone's alarms don't always go off the way that they're supposed to. They're all set and fine in the settings under the clock app, but sometimes they go off and sometimes they don't. I was beginning to think that if I disabled different sounds before bed (like turning off new mail notification, and sms) that this was the reason. But I have had mixed results, and subsequently can't quantify it in any way. The sound effect toggling seems to have no effect either way on whether or not the alarms work.

I usually turn those types of sounds off while leaving the phone ringer on so that I'm not disturbed, but if, god forbid, someone needed to call me in the middle of the night, I'd get the call.

But it's hard for me to feel comfortable about relying on my iPhone's alarm clock to get me up for work if it doesn't always do that very simple task! I've started setting backup alarms on watches again (which I used to do with my WM Treo, ugh, don't ask) and I'm not too happy about it. Has anyone else seen any kind of behavior like this or figured out a fix? Is it just a SW bug or my phone itself, and I need a restore or something? Any help would be much appreciated...
 

Jeremy

Retired Moderator
Mar 27, 2005
6,807
251
0
www.iMore.com
Next thing I would ask you is this... have you tried restoring and not from a back up file? Could be something in a back up file that is corrupt.
 

sethclifford

Well-known member
Sep 25, 2006
55
2
0
about.me
Never restored from a backup. Only updated to 2.0.2 when I first got the phone in August, and then 2.1. Do you think it's worth a clean restore and then re-add all my apps, etc?
 

Jeremy

Retired Moderator
Mar 27, 2005
6,807
251
0
www.iMore.com
What do you have to lose? Might as well give it a try. That sounds like a software issue. It's not a hardware issue.
 

sethclifford

Well-known member
Sep 25, 2006
55
2
0
about.me
Yeah, I was thinking the same thing. If I find the time in the next few days, I'll probably just do it. (and I'm sure I'll manage to find the time!)

Thanks...
 

MrEClass

Well-known member
Sep 12, 2008
219
1
0
Visit site
I hate the "restore-to-fix" issues that occur ever so often with the iPhone. I especially find it ludicrous when you have to restore because the simple and easy alarm function on the phone does not consistently work...it's a native app that Apple itself created...come on :rolleyes:

Anyway, Alienwhere I hope that restore fixes your issue, or better yet you don't even have to do the restore :eek:....but I may be just too hopeful
 

Jeremy

Retired Moderator
Mar 27, 2005
6,807
251
0
www.iMore.com
I hate the "restore-to-fix" issues that occur ever so often with the iPhone. I especially find it ludicrous when you have to restore because the simple and easy alarm function on the phone does not consistently work...it's a native app that Apple itself created...come on :rolleyes:

Anyway, Alienwhere I hope that restore fixes your issue, or better yet you don't even have to do the restore :eek:....but I may be just too hopeful

I'm guessing you've never used a Windows Mobile device? ;) Any WM user will tell you, it's all part of the game with phones like this.
 

MrEClass

Well-known member
Sep 12, 2008
219
1
0
Visit site
Oh no, I most definitely did use a WM device. It was a Pantech Duo C810 to be exact :eek:

I know sometimes a restore is really the only and quickest way to fix an issue with a WM phone and unfortunately, an iPhone as well, but it's a pain in the ass.

I didn't have many problems with that WM phone except for the fact that it was not up to par with speed when switching through different menus and slide orientation.

Good thing I don't have issue with my Iphone though.
 

ILBandit

Well-known member
Jul 4, 2008
50
5
0
Visit site
Mine has done that to me 1 time in the past few months. Almost made me late for work.
I tuned off the alarms, then turned them back on, and it has worked ever since.
Not sure what the deal was that caused it to not go off. I set a backup alarm for a few days after it happened, but now I'm brave again, and relying on the iPhone completely again.

P.S. You all think WM was bad for doing resets to fix glitchs, try the Palm OS! Resets are almost a daily occurence on my 680.
 
Last edited:

Rene Ritchie

Old Man Ritchie
Jan 12, 2007
2,115
355
0
www.about.me
My 680 crashed when making calls, receiving calls, or launching apps :(

I haven't had a problem with alarms yet. They wake me up from blissful sleep with shattering accuracy...
 

Tunnelrunner

Well-known member
Jul 7, 2008
251
4
18
Visit site
This JUST started to hapen to me the past 2 days. 2 alarms that are to set to go off DAILY didn't go off (1 yesterday) and my wake-up call (today).

I'm a little concerned here. Safari crashing at will, I know will happen. Push e-mail not always pushing, I know will happen. But the alarms not always sounding? A little ridiculous if you ask me.

Anyhoo, since I do daily soft reset, I think I'll do one every night just before I go to bed.
 

sethclifford

Well-known member
Sep 25, 2006
55
2
0
about.me
Not that I know of... I did a full restore, and it seems fine. Although it doesn't ALWAYS work. Occasionally I miss an alarm - usually only in the early morning hours.
 

Tunnelrunner

Well-known member
Jul 7, 2008
251
4
18
Visit site
Well, since I last posted on this thread, I've been doing a daily reset (power off) just before bed. So far, no more missed alarms. :knocks on wood.
 

Trending Posts

Members online

Forum statistics

Threads
260,311
Messages
1,766,353
Members
441,237
Latest member
Monser