1. daninuk's Avatar
    I've just JB my 3GS firmware baseband 05.11.07 through blackra1n by first upgrading to 3.1.2, then installing blackra1n and using Rock and Snow.
    However, after about 5 minutes my WiFi stopped working completely and all the settings are enabled.
    Does anyone know what could cause this and how it can be rectified?
    Any help would be much appreciated.
    Thanks.
    dan
    11-06-2009 05:11 AM
  2. sargd66's Avatar
    Reset network settings should do the trick.
    11-06-2009 06:12 AM
  3. daninuk's Avatar
    I did reset all network setings to factory defaults and restarted the iphone but there's no change.
    Basically, even if I try to connect manually I cannot because the WiFi itself does not function, it's like it doesn't exist. I have checked all settings again and although WiFi is enabled, 1.) it does not show any WiFi signal whatsoever and 2.) cannot join any network manually as there no signal being received by the iphone.
    Has anyone come accross simillar problem?
    Would a restore through iTunes to previous backup do the trick and would this wipe out my contacts etc?

    Thanks everyone.
    11-06-2009 06:50 AM
  4. sargd66's Avatar
    You might want to do a complete restore as new in Itunes. You won't lose contacts they are backed up. I then jailbroke again before I synced back with iTunes.
    11-06-2009 07:32 AM
  5. daninuk's Avatar
    After a complete restore, my WiFi is back on and I am planning on reinstalling blackra1n to JB. What I'm little confused about is which app is more stable/reliable, Cydia or Rock as it seam to be a debate on this.
    The itunes is now asking to restore my iphone so I do not know what to choose; as new iphone or prom previous back up.
    Thanks
    11-06-2009 08:04 AM
  6. sargd66's Avatar
    Restore as new is always the best way to go. I have both Cydia and Rock installed. The problem with Rock is you can't purchase alot of the apps through them only Cydia. Such as 3GUnrestrictor and PkgBackup. I think alot of people have both installed Cydia and Rock.
    11-06-2009 08:25 AM
  7. daninuk's Avatar
    So I have restored it to its factory settings through itunes and voila the WiFi signal is back on. I have then reinstalled blackra1n and installed Cydia and restarted the phone. Checked wifi signal and it was ok.
    HOWEVER after running SNOW the WiFi was desabled once again and there's no other option to regain the signal other than to restore the iphone AGAIN.
    Does anyone think of a cause/solution to this?
    Thanks.
    11-06-2009 08:30 AM
  8. sargd66's Avatar
    You did go in and reset network settings, right?
    11-06-2009 08:34 AM
  9. daninuk's Avatar
    yeah right, i did reset all network settings from the RESET menu but that didn't make a difference. Basically as soon as I have ran SNOW it stoppes working.
    So now I am left in limbo because I have just restored my phone to factory defaults and if I restore it's content from backup in order to sretrieve my contacts etc, it will automatically include the Cydia and settings modified by SNOW previously....
    11-06-2009 09:00 AM
  10. sargd66's Avatar
    Check the other threads there is a recent one about blackrain RC3. A poster named Ipheuria has some good posts about your issue.

    Jailbreak iPhone 3.1.2 with blackra1n RC3
    11-06-2009 09:11 AM
  11. daninuk's Avatar
    cheers, will do.
    11-06-2009 09:45 AM
  12. techshoe#WN's Avatar
    After I installed Rock through Blackra1n, my WiFi settings were disabled. Under WiFi it said "no wifi". For some reason, I could still browse the web, check mail etc. Really weird. A reboot fixed it.
    11-06-2009 10:48 AM
  13. daninuk's Avatar
    after couple of restores and going though the same process all over again I suspect that it is SNOW which causes the loss of my WiFi.
    Furhtermore, although the jaibreak went according to plan, I then rebooted and tried to unlock using SNOW. The process seamed to be succesfull, however, the WiFi signal is lost in a matter of minutes and then the iphone proved to be LOCKED still to o2 as it does not accept any other networks.
    So, if there's anyone out there who could think of a solution then I'd be glad to hear it.
    Just to confirm my iphone details:
    32GB 3GS 3.1.2 (7D11) firmware 05.11.07
    Jailbreaked using blackra1n but still LOCKED to o2
    11-06-2009 01:55 PM
LINK TO POST COPIED TO CLIPBOARD