HELP! No sound from loudspeaker, even after replacing speaker and 3.5mm dock (with reset)

jonib1988

New member
Apr 9, 2015
2
0
0
Visit site
IPHONE 5

Hi,

After suffering "the" charge port problem, in that the contacts wouldn't make a charge without moving the cable, I replaced the charge port connector. Immediately after replacing the charge port my loudspeaker stopped working - sound still worked through earphones.

Due to the forums reporting faulty with the loud speaker generally, I purchased a new loudspeaker but this repair was unsuccessful too.

Going back to my initial repair I thought I may have a defect on the 3.5mm jack that came with the new charge port, so I purchased another charge port and installed this with the new speaker. Still not sound from the loudspeaker.

I have now carried out both a soft and hard reset, checked the sound with Bluetooth and wifi off, but still no luck.

I really want to resolve this problem, rather than buying a new phone. Any advice would be appreciated
 
Last edited:

kch50428

Well-known member
Oct 22, 2010
21,025
305
0
Visit site
I'm tech savvy - but would not work on an iPhone... I'd go to an Apple Authorized service provider...
 

iEd

Banned
Jun 13, 2012
3,402
2
0
Visit site
IPHONE 5

Hi,

After suffering "the" charge port problem, in that the contacts wouldn't make a charge without moving the cable, I replaced the charge port connector. Immediately after replacing the charge port my loudspeaker stopped working - sound still worked through earphones.

Due to the forums reporting faulty with the loud speaker generally, I purchased a new loudspeaker but this repair was unsuccessful too.

Going back to my initial repair I thought I may have a defect on the 3.5mm jack that came with the new charge port, so I purchased another charge port and installed this with the new speaker. Still not sound from the loudspeaker.

I have now carried out both a soft and hard reset, checked the sound with Bluetooth and wifi off, but still no luck.

I really want to resolve this problem, rather than buying a new phone. Any advice would be appreciated

Get a new phone.


Sent from my iPhone 6 Plus using Tapatalk
 

HankAZ

Banned
Jul 26, 2012
6,092
0
0
Visit site
IPHONE 5

Hi,

After suffering "the" charge port problem, in that the contacts wouldn't make a charge without moving the cable, I replaced the charge port connector. Immediately after replacing the charge port my loudspeaker stopped working - sound still worked through earphones.

Due to the forums reporting faulty with the loud speaker generally, I purchased a new loudspeaker but this repair was unsuccessful too.

Going back to my initial repair I thought I may have a defect on the 3.5mm jack that came with the new charge port, so I purchased another charge port and installed this with the new speaker. Still not sound from the loudspeaker.

I have now carried out both a soft and hard reset, checked the sound with Bluetooth and wifi off, but still no luck.

I really want to resolve this problem, rather than buying a new phone. Any advice would be appreciated


Exactly what is "the" charge port problem? Are you saying that's really a "thing"? If repositioning the cable caused the phone to charge/not charge, how did you eliminate the cable as the problem before going all Frankenstein on your phone?

Just another reason to purchase AC+ and leave the fixing to Apple.
 

jonib1988

New member
Apr 9, 2015
2
0
0
Visit site
Exactly what is "the" charge port problem? Are you saying that's really a "thing"? If repositioning the cable caused the phone to charge/not charge, how did you eliminate the cable as the problem before going all Frankenstein on your phone?

Just another reason to purchase AC+ and leave the fixing to Apple.

Hi,

The charge port wouldn't work with any cable and it was due to worn contacts within the port. Changing the charge port is a common job and after changing this the phone charged fine.

To confirm, the charging of the phone is no longer a problem and the cables that wouldn't work before are now fine. A process of elimination was followed before dismantling the phone.
 

Walkyier

New member
Apr 14, 2016
1
0
0
Visit site
Hey I had the same problem after replacing the charge port. I put it back together and had no sound from my speaker. Took it apart and saw I had the cellular data cable laid out across one of the connection pads for the speaker. Has to be in a very specific spot for the speaker to make the connection. Pushed it off to the side so it was still connected to the logic board. Laid the speaker out on the pads, put it back together and now it all works. Simple to check. Hope it helps anyone with the same problem. Cheers!
 

ELLIEYES

New member
Jan 29, 2019
1
0
0
Visit site
Hey I had the same problem after replacing the charge port. I put it back together and had no sound from my speaker. Took it apart and saw I had the cellular data cable laid out across one of the connection pads for the speaker. Has to be in a very specific spot for the speaker to make the connection. Pushed it off to the side so it was still connected to the logic board. Laid the speaker out on the pads, put it back together and now it all works. Simple to check. Hope it helps anyone with the same problem. Cheers!


3 years later and you are receiving love from a stranger - me!

THANK YOU! Tried to fix my phone, but it seemed that everything I wrecked something more ha. This was the final thing that needed to be fixed. :) Thank you so much!
 

Trending Posts

Members online

Forum statistics

Threads
260,310
Messages
1,766,293
Members
441,234
Latest member
geas34