Mid 2012 MBP (Retina) stopped charging after weeks of Magsafe 2 acting weird (PLEASE HELP)

dave macbook pro

New member
Feb 2, 2019
1
0
0
Visit site
Mid 2012 MBP (Retina) stopped charging after weeks of Magsafe 2 acting weird (PLEASE HELP)

Very frustrated after days looking for a solution online, hope this forum can help me out...

So almost a month ago, the magsafe 2 light on my mid 2012 MBP (retina) starting acting weird, switching from amber to green light for no reason ... that was all the issue in the beginning. It wasn't really affecting anything... except some random restarts from time to time.

But, last week my computer starting to run out of battery fast and shutting off while it was still plugged in!

It mainly started happening every time I started rendering videos, which I know it uses a lot of resources and electricity.

I tried resetting SMC many times (Shift+Control+Option keys and the Power button at the same time, waited 5 to 10 seconds and let go). I did see the light change from amber to green after releasing the keys. Of course after a few minutes started to act up again and switching from green to amber.

So, little by little this started to happen more and more often until my computer would no longer charge while it was in use. It would ONLY charge if the computer was shut off. Let me remind you that it was still switching from green to amber light for no reason. However, I noticed that it was staying "mostly" amber while charging .. and then stayed "mostly" green while the battery reached 100% charge. At this point it was taking 8 to 9 hours to fully charge the battery while the computer was shut downed.

Well, a few days ago, it stopped charging completely! Not even when the computer is off. Also, no light was coming out at all, of any color. I tried resetting the SMC again, with no response at all!

Now all I get when I plugged the magsafe cord in, is static noises inside the computer (very low volume noises that kind of sounds like electricity maybe? very hard to hear unless you get your ear right next to the keyboard). I still have 70% battery left on my MBP since the last time I was able to charge it a few days ago (I'm being very careful and use it only when I need to). The computer seems to be working fine without the cord, and "seems" to be holding charge "normally". The computer itself seems to be working normally.

I just order a new cord, but I really have no idea what the problem could be. Specially since I'm getting weird noises when I plugged the cord into my laptop.

Any help or suggestions is greatly appreciated. I work at home (freelancer) so I'm kind of stuck now and it is hurting my business. Very stressful situation.

This is my latest power report I got from my laptop a few minutes ago... (cord unplugged since I don't know if it is actually hurting my computer by plugging it in)...

Battery Information:

Model Information:
Serial Number: D86235537FUDNMGA9
Manufacturer: SMP
Device Name: bq20z451
Pack Lot Code: 0
PCB Lot Code: 0
Firmware Version: 511
Hardware Revision: 000a
Cell Revision: 1150
Charge Information:
Charge Remaining (mAh): 4963
Fully Charged: No
Charging: No
Full Charge Capacity (mAh): 7245
Health Information:
Cycle Count: 346
Condition: Normal
Battery Installed: Yes
Amperage (mA): -1647
Voltage (mV): 11339

System Power Settings:

AC Power:
System Sleep Timer (Minutes): 10
Disk Sleep Timer (Minutes): 10
Display Sleep Timer (Minutes): 10
Wake on AC Change: No
Wake on Clamshell Open: Yes
Wake on LAN: Yes
AutoPowerOff Delay: 14400
AutoPowerOff Enabled: 1
DarkWakeBackgroundTasks: 1
Display Sleep Uses Dim: Yes
GPUSwitch: 2
Hibernate Mode: 3
PrioritizeNetworkReachabilityOverSleep: 0
Standby Delay: 4200
Standby Enabled: 1
Battery Power:
System Sleep Timer (Minutes): 60
Disk Sleep Timer (Minutes): 10
Display Sleep Timer (Minutes): 15
Wake on AC Change: No
Wake on Clamshell Open: Yes
AutoPowerOff Delay: 14400
AutoPowerOff Enabled: 1
Current Power Source: Yes
DarkWakeBackgroundTasks: 0
Display Sleep Uses Dim: Yes
GPUSwitch: 2
Hibernate Mode: 3
Reduce Brightness: Yes
Standby Delay: 4200
Standby Enabled: 1

Hardware Configuration:

UPS Installed: No

AC Charger Information:

Connected: No
Charging: No

THANK YOU SO MUCH FOR YOUR TIME AND HELP!
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,761
641
113
Visit site
If I had to guess, I’d say you need to replace both the battery and the charging cable. To be certain, I’d make a Genius Bar appointment with the nearest Apple Store to have them diagnose the problem for you.
 

cornettbr

Well-known member
Oct 30, 2012
375
0
16
Visit site
Google the power switching board, also replace the battery and potentially the MagSafe board. If it’s the power switching board and you are not solid with soldering you could be looking at a 2-400 logic board replacement “if” you do it yourself.
 

Trending Posts

Members online

Forum statistics

Threads
260,284
Messages
1,766,198
Members
441,232
Latest member
Gokox