1. gmz73's Avatar
    I went to reinstall the Facebook app this morning. When I clicked install the app store didn't ask for my password and now there is a gray box where the app would be and it is stuck on "waiting". I did a soft reset, closed all apps and it is still there. Any suggestions?


    Sent from my iPhone using Tapatalk
    09-24-2011 08:44 AM
  2. Eileen89's Avatar
    Try turning your iPhone off completely for a minute, then turn it on again and see if the app is there. When you go to the app store, does it say "Installed", next to the information about the app?


    Edit: The person in this thread had the same problem and it looks like a hard reset fixed it. Try that if turning your iPhone off and back on doesn't work. App stuck on iPhone 3G..tips/advice? [Archive] - MacRumors Forums
    Last edited by Irish Rose; 09-24-2011 at 09:05 AM.
    09-24-2011 08:54 AM
  3. gmz73's Avatar
    Yes it does say installed but the box is greyed out. There was also an update for the apple store app which I did but the update icon is still there. So I tried turning it off for awhile and that didn't help. Should I "reset all settings"? And should I go back it up first because there are some new things I did this week. I've never had one issue so I getting a little frustrated. Ugh!


    Sent from my iPhone using Tapatalk
    09-24-2011 09:35 AM
  4. Eileen89's Avatar
    Yes it does say installed but the box is greyed out. There was also an update for the apple store app which I did but the update icon is still there. So I tried turning it off for awhile and that didn't help. Should I "reset all settings"? And should I go back it up first because there are some new things I did this week. I've never had one issue so I getting a little frustrated. Ugh!


    Sent from my iPhone using Tapatalk
    Yes, if nothing else works, I would do this, and yes, make sure you perform a back up first. However, you mentioned that you did a soft reset, therefore, before you reset your settings, I would follow the short steps in this link to do a "Hard reset" first. That is what worked for the guy in the other link that I posted above. iClarified - iPhone - How to Hard Reset Your iPhone
    09-24-2011 09:58 AM
  5. gmz73's Avatar
    I just backed up my phone and that fixed the problem. Now Facebook showed as not installed and it allowed me to download it this time. Thanks!


    Sent from my iPhone using Tapatalk
    09-24-2011 10:06 AM
  6. Eileen89's Avatar
    You're welcome.
    09-24-2011 10:18 AM
  7. Calcifer2's Avatar
    I see this as well, occassionally. When it happens I just wait and after a few hours the problem resolves itself and the app is installed. Sometimes I have to wait for the next day! It must be something going on with Apple's backend
    09-25-2011 03:54 PM
  8. gmz73's Avatar
    I see this as well, occassionally. When it happens I just wait and after a few hours the problem resolves itself and the app is installed. Sometimes I have to wait for the next day! It must be something going on with Apple's backend
    Really? First time it happened to me but backing up fixed it quick.


    Sent from my iPhone using Tapatalk
    09-25-2011 04:11 PM
  9. Calcifer2's Avatar
    Maybe some process was blocking the update and the backup unblocked it. We have to guess what's happening since I've haven't seen Apple commenting on this issue.
    09-25-2011 04:14 PM
  10. robes1's Avatar
    Every time I have a problem like this I sync my phone and it's fixed. EVERY TIME!
    09-25-2011 08:41 PM
LINK TO POST COPIED TO CLIPBOARD