edge taking DAYS to set up sync, keeps opening blank new tab uncommanded on browser launch

xraiderv1

Well-known member
Mar 10, 2020
71
3
8
Visit site
crossposting on imore and windows central

-------

iphones:
one 6s plus
one 8.

os: ios 15.4.1
microsoft edge app version: 100.0.1185.43

os/app versioning is current for both devices.

-------

I'm about at my whits' end with this browser..at least once a day, I'll go to use it and instead of the last page I was on, there, practically shoved in my face, in spite of taking the nuclear option of a factory reset(for an unrelated issue), this app STILL does this.

its also been stuck syncing data to my microsoft account for DAYS now.

on BOTH of my Iphones.

I'm out of options for things I can do myself.

does anyone have any ideas how to fix these two problems, and or actually get actual support from the developer? kind of need a fix URGENTLY for this.
 
Last edited:

Annie_M

Moderator
Mar 2, 2016
21,894
768
113
Visit site
iphones:
one 6s plus
one 8.

os: ios 15.4.1
app version: 100.0.1185.43

os/app versioning is current for both devices.

-------

I'm about at my whits' end with this browser..at least once a day, I'll go to use it and instead of the last page I was on, there, practically shoved in my face, in spite of taking the nuclear option of a factory reset(for an unrelated issue), this app STILL does this.

its also been stuck syncing data to my microsoft account for DAYS now.

on BOTH of my Iphones.

I'm out of options for things I can do myself.

does anyone have any ideas how to fix these two problems, and or actually get actual support from the developer? kind of need a fix URGENTLY for this.

For clarification purposes, you are referring to Microsoft Edge aren’t you?
 

xraiderv1

Well-known member
Mar 10, 2020
71
3
8
Visit site
I'll duplicate the initial post over there. I'm just..I even turned off sync last night before bed since someone over on microsoft's pretty much useless forums said it may well be the sync having a problem.

..it opened a new tab first thing today. so yeah.
 

xraiderv1

Well-known member
Mar 10, 2020
71
3
8
Visit site
gave up on getting the phones to sync properly..they keep syncing, then refusing to do so, then going to 'setting up your sync', so I went and put adblock plus on safari and have both phones set up properly now.

still got the unusual edge activity, a ton of entries under disk dropdown on resource monitor, and the odd blue donut flicker next to my mouse arrow.

this unusual activity from edge only started after I reset sync.

though after following ms support(yes..they DO exist! I know right? shocked gasp anyone?) and resetting the browser, the frequency seems to have dropped off(as has the stutter flicker of the blue donut next to the mouse arrow).
 

Trending Posts

Members online

No members online now.

Forum statistics

Threads
260,230
Messages
1,766,006
Members
441,230
Latest member
lookie