1. kbtkpk's Avatar
    I use the application called "Files" v86 for syncing files between my Mac and my iPhone. About two or three weeks ago, a notice that there was an update available began showing up both in iTunes and in my iPhone. I have never been able to install the update. I have performed many the reset, of course. I have also tried to uninstall the app completely in order to reinstall it, but am unable to uninstall it, either! Every time I sync now, I get a message that Files could not be installed.

    I call Apple tech support about this. After a long time on hold, they could not come up with any suggestions. I asked them to escalate the issue. They promised to do so, but it's been about a week and I haven't heard back.

    Any ideas?
    10-10-2008 11:39 AM
  2. skuwamoto's Avatar
    You could try restoring your iPhone to factory defaults. This wipes out your phone and restores it from backup. In theory, your applications should be restored along with everything else.

    Restoring iPod to factory settings
    10-21-2008 07:41 PM
  3. kbtkpk's Avatar
    What I ended up doing was deleted all the files stored in Files. That finally allowed me to delete and reinstall the apps. Of course, if I end up having to do that frequently, the app will end up being as good as useless.
    10-21-2008 10:29 PM
  4. koso's Avatar
    The problem is in FILES application itself. In my opinoin,this is probably due to bug in Files aplication uninstalling process. In fact, old version Files aplication folder is not deleted, while new one is installed. (I tried to reinstall Files several times, and as I noticed later, in Application folder there were as many Files intallation folders as I Tried to reinstall). I was forced to solve it several times, in fact every time Files new version was out. As far as I know, there are two solutions:
    First one (and the only, if you running non jailbroken device): run iPhone "restore to factory settings" in iTunes or run "reset all content" right on iPhone (with NO RESTORE FROM BACKUP after that).
    Second one (jailbreak device required): in iPhone file browser (i-FunBox, iPhone Explorer etc.) go to USER - APPLICATIONS an find (folders are named by 32 digit number code) all "FILES" instalation folders and simply delete them. Restart iPhone and install new version of Files. For me always worked flawless this way.

    Hope this will help...
    10-22-2009 11:47 AM
  5. flyingember's Avatar
    just a heads up that for future use there's a section to this forum dedicated to applications

    http://forum.theiphoneblog.com/iphone-apps-games/
    10-22-2009 01:03 PM
LINK TO POST COPIED TO CLIPBOARD