1. TGB77's Avatar
    How is one supposed to go about keeping the phone from interrupting a video recording if an incoming call comes in?

    Here are a couple of sites which say one can keep the screen from being commandeered by an incoming call using the Do Not Disturb feature.

    https://m.wikihow.com/Block-All-Inco...iPhone-or-iPad
    https://www.iphonesavvy.com/tips/how...QJl2b10dVU_Xso

    1) Go to Settings > Do Not Disturb > toggle the switch on
    2) Go to Settings > Do Not Disburb > Allow Calls From > selected No One

    I followed the instructions at each of those sites and my screen is still commandeered by an incoming call. Are these sites accurate? If so, then my phone clearly isn't working as it should. If the sites are inaccurate, then how does one go about preventing an incoming call from interrupting a video recording?
    10-07-2019 12:36 PM
  2. Annie_8plus's Avatar
    I followed the instructions at each of those sites and my screen is still commandeered by an incoming call. Are these sites accurate? If so, then my phone clearly isn't working as it should. If the sites are inaccurate, then how does one go about preventing an incoming call from interrupting a video recording?
    We can't speak as to whether or not information on other sites is correct. Since you have tested them, and they don't seem to work, then I'd say the information is inaccurate. Unfortunately, I don't have an answer for you either. Hopefully, someone who has more experience in this area will come along and help you figure this out.
    10-07-2019 12:51 PM
  3. wenrob's Avatar
    Do you have “Always” selected and “Repeated Calls” off? If you don’t have “Always” selected then it will only silence the calls when your phone is locked.
    How to prevent incoming calls from interrupting video recording-adjustments.jpg
    10-07-2019 01:22 PM
  4. TGB77's Avatar
    Do you have “Always” selected and “Repeated Calls” off? If you don’t have “Always” selected then it will only silence the calls when your phone is locked.
    Click image for larger version. 

Name:	Adjustments.JPG 
Views:	0 
Size:	185.1 KB 
ID:	127113
    "Always" vs. "While iPhone is Locked" is under 'SILENCE'. That's not what this thread is about.

    Repeated Calls says 'A second call from the same person within three minutes will not be silenced'. Again, this pertains to whether or not the phone makes a sound.

    But 'Allow Calls From' if set to 'No One', it says 'When in Do Not Disturb, allow incoming calls from no one.'

    So I turn on Do Not Disturb, set Allow Calls From to 'No One' and call the phone from another phone and the incoming call commandeers the screen, halting the video process.

    Please try that on your phone and see if the incoming call displays.
    10-07-2019 06:44 PM
  5. wenrob's Avatar
    "Always" vs. "While iPhone is Locked" is under 'SILENCE'. That's not what this thread is about.

    Repeated Calls says 'A second call from the same person within three minutes will not be silenced'. Again, this pertains to whether or not the phone makes a sound.

    But 'Allow Calls From' if set to 'No One', it says 'When in Do Not Disturb, allow incoming calls from no one.'

    So I turn on Do Not Disturb, set Allow Calls From to 'No One' and call the phone from another phone and the incoming call commandeers the screen, halting the video process.

    Please try that on your phone and see if the incoming call displays.
    Wow, kind of a harsh response when someone is trying to help out/give you ideas. The best way to find out if it works or not is for YOU to try it.

    But, FTR, yes, I tested it out three times with my daughter’s help and her calls were sent straight to voicemail and did not take over the screen. I did not get the notifications until after I locked the phone and then unlocked it.
    10-07-2019 09:54 PM
  6. wenrob's Avatar
    Also, DND does not halt calls it just stops them from interrupting when you have it on. The call just gets sent to voicemail. eta: If you don’t have “Always” selected then the call will come through when the phone is unlocked.
    10-07-2019 09:58 PM
  7. Annie_8plus's Avatar
    @TGB77 - I realize that frustration can cause impatience. However, please remember that we are all volunteers here, doing our best to help each other figure out issues that we are having.
    10-07-2019 11:02 PM
  8. TGB77's Avatar
    Wow, kind of a harsh response when someone is trying to help out/give you ideas. The best way to find out if it works or not is for YOU to try it.

    But, FTR, yes, I tested it out three times with my daughter’s help and her calls were sent straight to voicemail and did not take over the screen. I did not get the notifications until after I locked the phone and then unlocked it.
    So you had 'Do Not Disturb' in the on position and selected 'Allow Calls From No One', called the phone and the call did not commandeer the screen, nor did it even let you know in any way at the time of the call that a call was coming in. Correct? If so, then your phone and my phone are functioning differently. This is very bizarre.
    10-08-2019 12:16 AM
  9. wenrob's Avatar
    So you had 'Do Not Disturb' in the on position and selected 'Allow Calls From No One', called the phone and the call did not commandeer the screen, nor did it even let you know in any way at the time of the call that a call was coming in. Correct? If so, then your phone and my phone are functioning differently. This is very bizarre.
    I also had “Always” on. That’s the key. You are taking the word ‘silence’ literally. If you don’t select “Always” then when your phone is unlocked it will let the call through. Otherwise, yes. No phone takeover and no notifications when set up this way:
    How to prevent incoming calls from interrupting video recording-img_9971.jpg
    Why not give it a try? We did three videos and no interruptions.
    Annie_8plus and FFR like this.
    10-08-2019 01:21 AM
  10. TGB77's Avatar
    I also had “Always” on. That’s the key. You are taking the word ‘silence’ literally. If you don’t select “Always” then when your phone is unlocked it will let the call through. Otherwise, yes. No phone takeover and no notifications when set up this way:
    Click image for larger version. 

Name:	IMG_9971.JPG 
Views:	0 
Size:	380.8 KB 
ID:	127119
    Why not give it a try? We did three videos and no interruptions.
    I had 'Always' selected, 'Do Not Disturb' in the on position and 'Allow Calls From' set to 'No One' and the calls went through, commandeering my screen and halting videos. Does this mean something is wrong with my phone?
    10-08-2019 05:55 PM
  11. wenrob's Avatar
    I had 'Always' selected, 'Do Not Disturb' in the on position and 'Allow Calls From' set to 'No One' and the calls went through, commandeering my screen and halting videos. Does this mean something is wrong with my phone?
    Are you using the same phone to call/test? Do you maybe have that person on Emergency Bypass?

    https://www.imore.com/how-receive-me...t-disturb-mode

    I can’t say if there is or isn’t anything wrong with your phone. Sometimes there are weird glitches. It did work for me though, specifically using the video feature. I also use it set up this way when I’m watching something on my iPad and don’t want to be interrupted.
    10-08-2019 06:20 PM
  12. kataran's Avatar
    I use Airplane Mode

    Always works
    scruffypig likes this.
    10-08-2019 06:30 PM
  13. scruffypig's Avatar
    I use Airplane Mode

    Always works
    I was going to suggest this also. Works like a champ.
    10-08-2019 07:19 PM
  14. TGB77's Avatar
    I double checked.
    'Do Not Disturb' > On
    SILENCE > Always
    Allow Calls From > No One

    Called my phone while recording a video > the video recording process halted.
    10-09-2019 03:32 AM
  15. Tartarus's Avatar
    I double checked.
    'Do Not Disturb' > On
    SILENCE > Always
    Allow Calls From > No One

    Called my phone while recording a video > the video recording process halted.
    With what app are you making the video calls?
    Apart from FaceTime video calls, all other video calls will be halted if someone calls you.
    10-09-2019 03:57 AM
  16. TGB77's Avatar
    With what app are you making the video calls?
    Apart from FaceTime video calls, all other video calls will be halted if someone calls you.
    I'm recording a video using the camera. This has nothing to do with video calls.
    10-09-2019 12:18 PM
  17. Tartarus's Avatar
    I'm recording a video using the camera. This has nothing to do with video calls.
    Gotcha. Apparently I misread.
    Nuclear option is to put the phone in flight mode, then.
    10-09-2019 01:34 PM
  18. TGB77's Avatar
    Gotcha. Apparently I misread.
    Nuclear option is to put the phone in flight mode, then.
    "Nuclear option" Well put.
    Yep, that's what I'll be doing from here on out. Airplane Mode.
    There doesn't seem to be a consensus on how 'Do Not Disturb' is supposed to work.
    Tartarus likes this.
    10-09-2019 04:19 PM

Similar Threads

  1. Here's your chance to save $30 on Amazon's Echo Plus smart speaker
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-07-2019, 12:12 PM
  2. Apple Arcade adds four new titles to strengthen lineup
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-07-2019, 12:12 PM
  3. Apple's quest for services super-bundle slowed by record labels
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-07-2019, 11:12 AM
  4. Microsoft To Do gains dark mode on iOS 13
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-07-2019, 10:51 AM
  5. Apple reportedly set to plough $200 million into ailing Japan Display
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-07-2019, 08:30 AM
LINK TO POST COPIED TO CLIPBOARD