1. Mercifull's Avatar
    I am new to iPhones and have just got an iPhone5 as upgrade from an old Android phone. It was set up as brand new and I didn't use any tools to transfer contacts, photos or settings.

    I am able to connect to my home WiFi network fine and I have connected it to my parents wifi as well.

    The issues seems isolated to corporate/public/subscription wifi connections (apologiues I don't know the correct name) where on connection a popup is supposed to appear to let me type in a username and password to enable the device to connect to the internet.

    When I connect to the network the WiFi symbol appears a few moments later but no login box appears. If I go to Safari there is no redirect to the page either instead the browser just hangs until eventually displays a message saying no internet connection. Chrome doesnt work either.

    I have tried switching the entire phone off and on again, I've "forgotten" the network a dozen times, I've turned the wifi on and off again. I've cleared the Safari cache and ensured that autofill is off. I've also reset the network settings to try again from scratch and yet it still doesnt work.

    Please help.

    To clarify. I appears that the connection is a success and i am assigned an ip address etc. However I get no option to enable the device either by clicking the name of the network in the wifi settings or by trying to navigate to a webpage in safari

    p.s also tried changing proxy to auto, didn't work either.
    09-24-2012 05:02 AM
  2. Mercifull's Avatar
    Almost 50 views, no responses. Has anyone else ever come across this error in the past even?
    09-24-2012 07:14 AM
  3. anon(4698833)'s Avatar
    I have never personally seen this issue except when a WiFi area is clogged with users (IE: Sporting Event, packed Starbucks, etc)...yesterday i was near Turner Field waiting for someone and signed into their WiFi network (which does the same thing, where you sign in from a webpage and become "authorized"), it functioned just fine and i added it to my saved networks.

    Have you tried manually adding the network?
    09-24-2012 07:20 AM
  4. Mercifull's Avatar
    Tried it last night at a different hotspot and it connected fine with the popup. Could be a configuiration error on the work network but seems odd that other iPhone4S's and androids connect fine.

    I'll try adding it manually.
    09-25-2012 02:06 AM

Similar Threads

  1. Unable to Join WiFi
    By iphone999 in forum iPhone 4
    Replies: 3
    Last Post: 03-07-2012, 08:54 AM
  2. Replies: 1
    Last Post: 01-13-2012, 07:16 AM
  3. Public wifi in Canada: how common?
    By Massie in forum iPhone 4
    Replies: 2
    Last Post: 07-04-2011, 02:18 PM
  4. Unable to join wifi
    By jtanko78 in forum iPhone 4
    Replies: 7
    Last Post: 02-21-2011, 04:36 PM
  5. Constantly Pulling Up Public Wifi Login Pages
    By Jellotime91 in forum iPhone 4
    Replies: 8
    Last Post: 09-20-2010, 12:37 PM