1. Statto's Avatar
    My iPhone 4 has developed a very strange problem

    I am connected to my home wifi network, and this is clearly OK in the Settings/wifi setup.

    However, the device refuses point blank to show the wifi icon in the info bar at the top of the screen. The only way I can get it to display is to go into Settings/General/Network and turn "Cellular Data" to off whereupon the wifi icon appears instantly. The problem then is once out of wifi range I've got no 3G

    Nothing (to the best of my knowledge) has been altered in any of the other settings and it was working fine last night before I went to bed.

    I've tried resetting the network settings to no avail, and have turned the device on and off several times. My son's 3G is picking up the and displaying wifi fine.

    What's bizarre is settings shows I'm connected to wifi

    Any suggestions?

    Thanks

    Stats
    09-02-2010 02:42 PM
  2. big9erfan's Avatar
    Have you tried restoring your device as new to see if it fixes the issue? ( ie do not restore from backup )
    09-02-2010 02:47 PM
  3. Statto's Avatar
    Not yet - rather there was an easier solution!
    09-02-2010 02:51 PM
  4. big9erfan's Avatar
    I think this is the easiest solution you'll find. I've not heard of this problem before, and read these forums far too often =P
    09-02-2010 03:23 PM
  5. Statto's Avatar
    Router re-boot sorted it!
    09-02-2010 04:27 PM
LINK TO POST COPIED TO CLIPBOARD