1. matthew23's Avatar
    I seem to be having an issue with the camera roll folder on my iPhone 4. Two issues, I am not sure if they are related.

    1) On the phone, when I am in camera roll and try and delete a picture, it does not delete correctly. I hit delete and it either does not delete (it just stays there) or if it does, it leaves a black box where the picture used to be until I exit out of the camara program or take another picture which replaces the black box. Very ugly and there is a clear issue.

    2) When I try to import pictures taken with a 3rd party camera app (ie hipstamatic), iPhoto does not recognize those pictures when it goes to import photos on off the phone. Pictures taken with the stock camara app appear fine but ones by Hipstamatic or other 3rd party apps only appear as blank thumbnails (a dotted-line box with no picure in middle). I can import them if I hit import, I just cannot view them when the iphone is initially connected for apreview of what picture I want to import off the phone...

    Anyone else having these problems? I hope I described it well enough!

    Thanks!
    06-30-2010 10:48 AM
  2. Fausty82's Avatar
    Yes, some are seeing this... I did see it once very early on, but not since.

    http://forum.tipb.com/iphone-forum/1...ml#post1593030
    06-30-2010 11:02 AM
  3. Duvi's Avatar
    Yup... happened to me the other day. It hasn't
    happened after that one time. Then again, I
    rarely use the camera app, so when I do, I'll
    check to see if it happens again.
    06-30-2010 11:07 AM
  4. matthew23's Avatar
    Good to see its not just me! I am more concerned about the iPhoto issue. Importing pictures from my 3GS was perfect. It seems there is some glitch between iPhoto, the iPhone (or iOS4) and the 3rd party camera applications.
    06-30-2010 11:09 AM
  5. Duvi's Avatar
    I use windows
    06-30-2010 11:19 AM
  6. Ipheuria's Avatar
    OP I can't talk about the 3rd party app because it is 3rd party that's a different bag of tricks. It sounds like the database file that holds the picture locations may have been become corrupt so what I would suggest to try is to take all the pictures off the phone in all apps. Then sync the phone and reboot the phone this should reset the file of sorts. Then first shoot a picture with the camera app and see what happens when you delete it. Then try your 3rd party apps and see what happens. This shouldn't be a re-occuring problem so if it happens again I would suggest taking it in to Apple.
    06-30-2010 11:56 AM
  7. matthew23's Avatar
    Thanks, I did try your suggestion and deleted all photos. Problem comes and goes - I cannot figure it out. However, I do not think that it is just my phone as other people have cited the issue as well...I do hink it has to do with the picture database getting corrupted though...
    06-30-2010 12:21 PM
  8. scottdoc718's Avatar
    I've had this happen to me once. The black box, that is.
    06-30-2010 12:27 PM
  9. immel's Avatar
    I had the same blank thumbnail issue with the IOS 4 update. I tried this and it works.
    With Iphone Explorer, open the Photodata folder. Save (to your PC), and then delete these three files:

    Photos.sqlite
    Photosaux.sqlite
    com.apple.photos.caches_metadata.plist

    Restart Photos in Iphone and it will rebuild your photo library with the thumbnails intact.
    07-19-2010 04:45 PM
  10. iVenom's Avatar
    what happened to being able to make albums on the phone or did i make that up? i have 850 pics on mine i hate hunting for pics to add to contacts, or to show of my baby. im on window too so no iphoto.
    07-19-2010 06:25 PM
  11. chobbs1's Avatar
    Are the third party apps ios4 compatable? I haven't had the black thumbnail thing yet
    07-19-2010 07:23 PM
  12. jetro_76's Avatar
    I had the same blank thumbnail issue with the IOS 4 update. I tried this and it works.
    With Iphone Explorer, open the Photodata folder. Save (to your PC), and then delete these three files:

    Photos.sqlite
    Photosaux.sqlite
    com.apple.photos.caches_metadata.plist

    Restart Photos in Iphone and it will rebuild your photo library with the thumbnails intact.
    Hey you should be working for the APPLE company for 4 months ive been looking for a solution to the "Black Blank Camera Roll" luckily i didnt delete all the photos and start a new camera roll after following what you have explained it did fix my problem, im just hoping that its not too late for the other people ho has the same problem. All i can say is your a genius THANK YOU!!!! very much. Now im back taking pictures and showing people with no embarassment that they will see those "Black Blank "Thumb Nails on the Iphone camera roll........cheersssss.

    PS: for those people who's gonna try and fix the problem, You have to download the "IPHONE BROWSER" its free.
    08-07-2010 03:39 AM
  13. Duvi's Avatar
    All I did was sync my iPhone to iTunes and reboot. The problem went
    away.
    08-07-2010 02:30 PM
LINK TO POST COPIED TO CLIPBOARD