1. DROGTURIST's Avatar
    Hi. My phone broke today and it won't restore.

    I am getting error (9) every time I try. I have tried using a different cable, different port, different computer (that didn't have iTunes on it to begin with), reinstalled iTunes, I found a YouTube video that suggested removing all files from Application Data\Apple Computer so I moved those, and I've tried recovering from both normal recovery and DFU mode (I think, it's hard to know that you've succeeded). Error (9) every time.

    I have a 3.1 OOTB iPhone that was upgraded to 3.1.2 today. I originally had an issue where something happened to the root password (SSH just stopped taking it and I didn't switch it), so I successfully restored and then when I wanted to install Winterboard the phone just froze for an hour on the Apple logo. Restored again and got further that time, but after installing CategoriesSB, the Springboard seemed to permanently break and every time I made an SB refresh I got dumped in safe mode -- and the only way out of that was using Categories' SB refresh.

    Went for another restore and that's when I was just stopped dead in my tracks; error (9) every time now after dozens of attempts.

    Somewhere along this line, iTunes lost track of my backed-up data so that seems to be completely gone now.

    The only thing I can think of is that my phone and jailbreak hates 3.1.2, as I was running on 3.1 until it updated when I did my first restore. But there was no other option but "update and restore," and I thought 3.1.2 was cracked so I just allowed it. Was that a really bad idea? Can I go back to 3.1 somehow?

    Any help is hugely appreciated. I've only had my 3GS for two months, meaning I have 22 months of contract for it left.
    11-13-2009 02:01 PM
  2. Hack-My-i's Avatar
    Do u have warranty...i would take it to the apple store to get checked out if its taking that much time to do a restore
    11-13-2009 02:07 PM
  3. DROGTURIST's Avatar
    Thanks for the response! However, it's not taking time, it's just not starting the restore at all...

    I do still have 10 months warranty, if I can trick them into fixing it without knowing that it's JB'd. Anyone know how hard it is to walk into an Apple Center with a non-booting JB'd iPhone?

    I should add that I did something I hadn't done before, I ran the blacksn0w unlock. But it said it went fine and that was after my very first restore, so I did succeed in doing another restore after the unlock...
    11-13-2009 02:16 PM
  4. flyingember's Avatar
    they'll claim your problem was caused by the jailbreak and they could be right

    you basically ran some procedures that have a risk of breaking your phone
    11-13-2009 03:02 PM
  5. big9erfan's Avatar
    Have you tried putting the phone into recovery mode or DFU to restore it?
    11-13-2009 03:36 PM
  6. DROGTURIST's Avatar
    they'll claim your problem was caused by the jailbreak and they could be right
    Most likely, which is why I won't tell the rep! He won't be able to tell until he gets it to boot (if he can) anyway...

    Have you tried putting the phone into recovery mode or DFU to restore it?
    I believe so. Recovery mode is when you see a cable pointing to iTunes, and DFU is when the screen is black but iTunes pops a question saying it found a phone that needs restoring, right? If those are the modes, I've done it to no avail.
    11-14-2009 04:16 AM
  7. Ipheuria's Avatar
    From your thread you tried so many different things it's so all over the place. You need to just start from scratch and slowly try it again. So I would say power it off and let it sit for a few minutes. While it's off make sure you have the newest iTunes. Start iTunes up hold the home button and keep holding the home button and plug in the USB cable. The phone should boot keep holding the home button until it's in DFU mode and iTunes should tell you that a phone is in restore mode. Ensure the auto-lock on the phone is on Never and the sleep and hibernate and screensaver on your computer are off. Then restore the phone with OEM Apple 3.1.2 firmware. Once thats done grab blackra1n put your phone in airplane mode and JB & UL. If that doesn't work take it in to Apple Obviously removing the JB and have them take a crack at it. The problem doesn't necessarily have to be caused by JB. I had a friend ask me to JB and UL his phone but he was already on 3.1 so I was in the process of upgrading to 3.1.2 nothing to do with JB yet and the genuine process gave me an error and I ended up wiping the phone.
    Last edited by Ipheuria; 11-14-2009 at 02:29 PM.
    11-14-2009 02:25 PM
  8. Ipheuria's Avatar
    Any Update??
    11-16-2009 07:39 AM
  9. DROGTURIST's Avatar
    Thanks for the suggestions! I have taken all of them into account, but am still stuck on error (9)... Even took it to Apple who can't fix it in my country (due to the contract they have with the carrier here), but they seemed to agree that error (9) is unfixable and I should just send it off for repairs.

    So I'm gonna go ahead and do that and hope that they don't care that I'm jailbroken. I don't think I have any other options left...
    11-16-2009 11:19 AM
  10. chobbs1's Avatar
    They are going to charge you a pretty penny for fixing it because it is JB'n. Jailbreaking voids your waranty
    11-16-2009 11:33 AM
LINK TO POST COPIED TO CLIPBOARD