1. confrontation's Avatar
    my wifi just suddenly stopped working.
    it cant find any of the 2 networks I use.
    I tried putting the settings in for each network , but no luck.
    I restored the firmware but no luck.
    was working this morning before i went to work, I shut the wifi ofbefore leaving the house.

    any ideas?
    07-03-2009 04:39 AM
  2. PirateNinja's Avatar
    also happened to my 3G

    i just turned the phone off and back on, wifi worked again after that restart
    07-03-2009 06:02 AM
  3. thatiphoneguy's Avatar
    That's weird, I got a new refurb 3g from apple recently and this thing will not connect to my wifi network. It's odd, it finds the network then for some reason drops it and won't find it again.. I am baffled.
    07-03-2009 02:27 PM
  4. lordzod01's Avatar
    Mine started doing this yesterday. I don't get any wifi networks now. I did 2 restores still no joy. I'm taking it the genius bar this week. I spoke to someone at Apple and they think my GPS chip has burnt out. Ever since 3.0 my 3g has been red hot when i'm using it.
    07-03-2009 03:55 PM
  5. Caballera's Avatar
    I was having a similar issue and I followed the instructions from the apple support site (unfortunately I can't post links). Specifically:

    "Unable to Join Network Failure (error -3)" connecting to Wi-Fi
    If you are receiving the error message "Unable to Join Network Failure (error -3)" on the iPod touch or iPhone when attempting to connect or join to your Wi-Fi network, verify your Wi-Fi Network Name (SSID) and Security setting (WEP password, WEP hex or ASCII, WPA, or WPA2) for the device.

    On the Wi-Fi Access Point/Router, you should verify if MAC address filtering is turned ON or OFF on the router, whether the security settings on the router match the iPod touch or iPhone (WEP password, WEP hex or ASCII, WPA, or WPA2), and try disabling (QoS) quality of service if that feature is turned ON for the router.

    If you are still receiving the error message "Unable to Join Network Failure (error -3)" on the device when attempting to connect or join to your Wi-Fi network after trying the above suggestions, tap Settings > Wi-Fi > Other (under Choose a Network) and then enter the Wi-Fi Network Name (SSID) and select your Security setting and enter your password."
    I just made sure I was connected via WPA2 and reentered my password.
    07-03-2009 05:33 PM
  6. lordzod01's Avatar
    I've been to the genius bar with this problem now. Apparently Apple know about it but there is no fix at the moment. They reset network settings, messed around for a-while and i leave no better off. According to the bar there is a bug in 3.0 dissableing wifi over the full range of iPhones and Touches.

    Has anybody heard of a fix over JB without going back to 2.2.1?
    07-06-2009 08:55 AM
LINK TO POST COPIED TO CLIPBOARD