1. Lonative's Avatar
    I currently have a 6 gb iphone 4 jailbroken by redsnow software 5.0.1.
    Since my mom has an 18 gb iphone 4 , I want to trad with her.
    This means I would have to restore my iphone to her backup and jailbreak hers.
    While I was restoring mine, it required a 5.1.1. system update . So I let it do that, but it gave me an error stating "There was a problem downloading the software for the iPhone "Lauren" The network Connection timed out.Make sure your network settings are correct and your network connection is active"
    So i tried to update it to 5.1.1 via the device and wifi. Same error..
    I tried updating my moms phone, and it worked fine. So it's not the network connection..
    How can I restore it to my moms iphone backup ..?
    Thank you so much.
    05-31-2012 03:09 PM
  2. Lonative's Avatar
    I tried syncing with my firewall turned off. A new message came up and said "iPhone could not be restored because the firmware file is not compatible"
    05-31-2012 03:21 PM
  3. Peligro911's Avatar
    Down load the 5.1.1 Ipsw file to your desktop and the in iTunes do a shift restore and select the file

    Sent Into Orbit from my iPhone 4S using Tapatalk
    Lonative likes this.
    05-31-2012 03:30 PM