1. jbaibl33's Avatar
    I just performed redsnow jailbreak 4.3.2. for iphone 4 and now my email won't work - both gmail and exchange.

    I tried re-doing the jailbreak process. and re-installing the email accounts, but have been unsuccessful. When setting up gmail i get error message: Cannot Connect Using SSL. Exchange seems to get through the set up, but I cannot view any mail once it's completed.

    Also, I just tested a yahoo account and that does not work either.

    Can some please help???
    05-02-2011 10:40 AM
  2. liquidzoo's Avatar
    I've had no issues. Have you tried doing a restore on your phone? That might resolve the issue for you.
    05-02-2011 02:52 PM
  3. jbaibl33's Avatar
    Do you mean restoring to the pre-jailbreak version? If not, what do you mean?
    05-02-2011 02:57 PM
  4. Ipheuria's Avatar
    I have no issues and I use both Gmail and Exchange. I've had problems setting up my accounts whenever I was going through 3G and the connection wasn't stable. It might also be a problem with firewall if you're at work? I would also say put the phone back to stock 4.3.2 and see if you're able to setup the emails. If you are then set them up and re-JB redsn0w doesn't reload the firmware so the accounts should remain.
    05-02-2011 04:34 PM
  5. jbaibl33's Avatar
    Thanks for the response. Won't I lose all the jailbreak apps I bought?
    05-02-2011 04:44 PM
  6. liquidzoo's Avatar
    Cydia will remember your purchases, though you may have to download and reinstall them.
    05-02-2011 04:53 PM
  7. jbaibl33's Avatar
    I can set up the email accounts (and they work perfectly) when in safe mode, but under a normal jailbroken start-up neither of them work!
    05-02-2011 05:30 PM
  8. jbaibl33's Avatar
    When I open mail in regular mode I see only blank messages and I am not able to send any. Gmail gives me the message: No password provided.

    So when I go into settings and enter my password I get "The IMAP Server "imap.gmail.com" is not responding......

    like I said, both gmail and exchange both work perfectly in safe mode. Can anyone help?

    I have already tried to re-jailbreak but no luck
    05-02-2011 05:44 PM
  9. brulez's Avatar
    I had this exact same problem. This thread is old, but it comes up as one of the first google results so just incase someone else has this problem, here's how I solved it.

    I had lockinfo installed and setup to bypass the lock code. Under settings->lockinfo->advanced, set Data Protection to "On" and turn off the lock code bypass. It seems that having data protection enabled was messing with the ability to use SSL.

    I suppose a similar app to lockinfo that disables data protection could also cause this issue.
    06-06-2011 01:39 AM
LINK TO POST COPIED TO CLIPBOARD