1. sting7k's Avatar
    This has been driving me crazy for over an hour now. I get no data to load over 3G at all. I just talked to a friend in Philly, I'm north of DC. He says he also has no 3G data even though both our phones say they have full signal on 3G. A thread just popped up on Apple's forums of lots of people saying they are not getting any 3G data to load. I also talked to another friend who has a company issued Samsung Jack, his 3G data is working fine, he lives 2 miles from me. My friend in Philly and I both have iPhone 4's. Any 3G or 3GS users getting data to load over 3G?
    06-30-2010 01:36 PM
  2. big9erfan's Avatar
    3G data on AT&T working fine here in So Cal.
    06-30-2010 01:47 PM
  3. tefloncoated's Avatar
    did you restore/set up from a jailbroken back up of your old iphone? is your MMS gone too? - if so, known issue. search.
    06-30-2010 01:55 PM
  4. sting7k's Avatar
    Nope, restored as new. Not/never jailbroken. Can call, text, mms, facetime fine. EDGE also works. Only 3G data is not working. My bro just got home and his 3GS is working fine. There is now a thread on Apple's forum with reports of the same thing, iPhone 4's with no 3G data.
    06-30-2010 02:05 PM
  5. jerseymacman's Avatar
    I am in the Northern VA area and I am having the same issue with my Iphone 4. I wemt to settings and turned of 3g then turned it back on and it starting working again. Then it went out again, and I had to reset 3g again. There must be something wrong with AT&T's network in this area.
    06-30-2010 02:21 PM
  6. Duvi's Avatar
    I believe I'm having some issues myself. First time
    I've ever seen my iPhone fluctuate, but my 9700
    BlackBerry is doing the same, going from 3G to EDGE.

    I'm already at 67% and it's only 2:30pm EST. I've
    had the i4 off the charge since 12:15am EST with
    only 2 1/2 hours of usage.
    06-30-2010 02:39 PM
  7. Duvi's Avatar
    Btw... I'm in North NJ, NYC area.
    06-30-2010 03:08 PM
  8. Garz's Avatar
    Ive been having data issues on 3G off and on since Ive had it will full bars of 3G. My wifes 3GS has been perfect. Ive restored as new, reset network setting and had Att reprovision my data plan last night. So far today has been better but time will tell
    06-30-2010 04:02 PM
  9. sting7k's Avatar
    About an hour ago data started working again over 3G. I tried to call AT&T but their lines were very busy and I didn't feel like waiting. At first it was working but about dial up speeds. Right now it's working but at about 700kbps download and the upload is normal at about 800kbps. On my 3G I used to average around 1300/800. Still says I have full signal.

    Just got to work and 2 guys also with iPhone 4's also said they were not getting any 3G data or it was very slow all day. People with 3G/3GS said they had no problems.
    06-30-2010 05:26 PM
  10. iPhone4User's Avatar
    My refreshed IPad monthly data plan is unlimited and started 4 days ago (recycled)
    07-11-2010 05:42 PM
  11. 78RN's Avatar
    My wife and I got our iphone 4s two days ago and the 3g data has been very sketchy. When it does work I get data speeds double what i would get withmy 3G iphone.... That's when it is actually working. When the 3G stops working I switch to WIFI (when available) and it works great, all apps run great.

    I am in NJ...

    Anyone kow of a fix?
    08-05-2010 11:44 PM
LINK TO POST COPIED TO CLIPBOARD