1. iMore Question's Avatar
    i just got a new plan and switched my sim card and imessage will no longer activate with a phone number and will only send from an email address. i dont want this what do i do?
    04-30-2014 11:16 PM
  2. nikkisharif's Avatar
    i just got a new plan and switched my sim card and imessage will no longer activate with a phone number and will only send from an email address. i dont want this what do i do?
    Go into your contacts and find your contact and edit it so your number lists as an iPhone. Then go to settings > messages > send & receive & select your number
    04-30-2014 11:41 PM

Similar Threads

  1. Replies: 1
    Last Post: 05-01-2014, 09:00 AM
  2. T-Mobile adds 2.5 million new customers in Q1 2014
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 05-01-2014, 08:40 AM
LINK TO POST COPIED TO CLIPBOARD