Why is my Ipod insisting it is up to date?

I

iMore Question

About a year ago, my brother gave me his old Ipod as a present, since he didn't need it anymore. I finally decided to go ahead and update it- only for it to insist that it's current version, iOS 6.1.6, is up to date. Considering that I know the -actual- version is somewhere around 8.0, this is, needless to say, -very- frustrating. There are a few apps that I wish to install or update, that cannot do so until I update my iOS. Has anyone else had this problem?
 

Trending Posts

Members online

Forum statistics

Threads
261,100
Messages
1,769,573
Members
441,290
Latest member
bradkdoesntcare