• Welcome to the all-new iMore Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

Very tough problem with iPhone 4s, any help with a fix?


iMore Question

Very tough problem with iPhone 4s

Bear with me. If you know how to fix this, then you should really do pro work my friend. Here i go.

My friend gave me a white iPhone 4s last week. He told me the sleep/power button was broken and when he tried to plug it into his computer the phone would turn on in restore mode (plug sign with itunes logo). Because i had fixed my ipod touch 4 with the same issue, i thought fixing this wouldnt be too tough. But i was waayyyyy wrong. I plugged it into my computer and tried to do a restore (itunes told me it couldnt be updated) but it was stuck on waiting for iphone. I had to stop the restore and try it again. After that it began having some more problems. Every time i plugged the phone in the apple logo would flash for 1 second then turn off for 1 second and repeat until i unplugged it. I eventually found out holding the home button just before plugging it in got it back into restore mode. Remember that the power button is broken so i dont have many options. I tried using redsn0w 0.9.15b3 to create a dfu version of the ios 6.0 ipsw for iphone 4s then using shift click to select it and restore with itunes 11.0 and even the latest. This time after extracting it said the restore failed for an unknown reason. I was about to try this again or go another route but now when i plug the phone in it does the same flashing routine, but this time i cannot get into recovery mode (the iphone would hold the apple logo when i hold the home button, now it dosent). So first it was stuck in recovery mode, then it got stuck in the flashing apple of death but was still fixable, and now its in the flashing apple logo of death with no power button and no response from the home button. WTF!

If anyone can help me fix this mess you are a god!

Ask The Community

Trending Posts

Members online

Forum statistics

Latest member