Changes in 3.0 beta 2 (from beta 1)

Muero

Well-known member
Jun 4, 2008
101
0
0
Visit site
Here is what I've noticed so far.

  • Modem firmware has been updated once again, from 04.20.01 to 04.22.01.
  • New user agent string:

    Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/3.1.1 Mobile/7A259g Safari/525.20
    Here's the old one, with the only change highlighted.
    Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.11 (KHTML, like Gecko) Version/3.1.1 Mobile/7A238j Safari/525.20
  • Skype can still make calls over 3G (this is supposedly a feature/bug of 3.0 OS only).
  • The generic "syncing" in iTunes still takes forever.
  • Everything feels much smoother and less laggy. Like night and day difference. There will probably still be some more improvement in this area before the full release, but at least it's usable now.
  • In beta 1, the up arrow would not be highlighted automatically even when the auto-capitalization was triggered (like when putting in names), which left me always wondering if auto-capitalization was going to affect the next letter I put in. Now, it correctly shows when it's going to capitalize a letter.
  • In beta 1, I could not get the app "What's On?" to work. It was impossible to set up a new location. Now, it works fine.
  • Google Translate (in Safari) still does not work. I don't know if this has something to do with Safari or what the problem is.
  • Despite Apple's insistence in the release notes that MMS should not be used, MMS still works fine (other than being blocked by AT&T).
 
Last edited:

Jeremy

Retired Moderator
Mar 27, 2005
6,807
251
0
www.iMore.com
I heard in fact MMS is not being blocked by att currently and people are using it with no issues without using any hacks... I have not tried it myself yet.
 

Muero

Well-known member
Jun 4, 2008
101
0
0
Visit site
I have tried sending MMS several times and always get the same error message as before. Also, holding down the home button still does absolutely nothing (doesn't force quit an app like on 2.x).
 

davidgoduke

New member
Mar 30, 2009
2
0
0
Visit site
I've heard that the 16GB models are having trouble sending MMS, but the 8GB models are doing it fine. Muero, do you have a 16GB or 8GB? I know it's strange but it seems to be the problem.
 

shutter

Well-known member
Jan 13, 2009
830
19
18
Visit site
I have tried sending MMS several times and always get the same error message as before. Also, holding down the home button still does absolutely nothing (doesn't force quit an app like on 2.x).

I haven't figured out how to force quite the ipod yet...but with safari...just close all tabs before you exit. If I do that and then run free memory or memory info 1.4....safari is not listed as a running process.
 

Jeremy

Retired Moderator
Mar 27, 2005
6,807
251
0
www.iMore.com
No mms here but all the other bugs I encountered in beta 1 are gone so I am pretty happy. No lock ups or slowdowns for me so far.
 

JustinHorn

Well-known member
Aug 3, 2008
1,284
5
0
whenwillapple.com
No MMS for me either, 16GB 3G. I think it's the phone because I have the family text plan and I don't get the view my messages SMS. So I think once the phone supports it I will be good to go. I guess I could hack the carrier file, but I don't care enough to screw with that.
 

seaborn

Member
Feb 26, 2009
6
0
0
Visit site
No MMS for me either on Rogers in Canada. Not even the option to add a photo or file in Messages Still awaiting :)

As for changes since Beta 1. A lot of bugs and sluggish issues have been fixed as well.

Although I am still seeing a significant lag opening up the Messages Icon. Sometimes up to 2.5 seconds. Although it could have been the same in 2.2, Can't quite remember now.
 

Duvi

Well-known member
Jun 17, 2008
2,063
18
0
Visit site
Here is what I posted over at Crackberry.

WoW - First thing that came to mind. I installed beta 2 today (never tried beta 1).

The few things that I've noticed off hand...

The numeric battery meter was still there along the normal one meter. I use the numeric jailbreaking.

MMS... I attempted to send one and it worked to both recepients. They received it fast too.

Copy and Paste... smooth. Definitely better than the Storms. I was copying and pasting in Safari! Awesome.

Spotlight... I'm not going to use it, but it's pretty good.

Double-Click Home... can now be set for the following: Home, Search, Phone Favs, Camera & iPod. I set it to camera. Couldn't help it... it's like my right convenience on my BB.

Good stuff; no lag for me. I do find it very hard to move apps that are on home page on the right and go to a home page on the left. I'm not sure if that's 3.0 or iPhone specific as I never really moved left before.
 

Duvi

Well-known member
Jun 17, 2008
2,063
18
0
Visit site
Also I sent 5 mms pics and noticed when I hit edit, it showed as though they sent 5 different messages. I'm going to call the person tomorrow and ask them how they came in.
 

Rene Ritchie

Old Man Ritchie
Jan 12, 2007
2,115
355
0
www.about.me
MMS is mostly completely missing from Rogers 3.0 installs I've seen. Didn't realize iPhone OS was customized to that degree by region?
 

dooks88

Well-known member
Jan 23, 2009
186
2
0
Visit site
Here is what I posted over at Crackberry.



Good stuff; no lag for me. I do find it very hard to move apps that are on home page on the right and go to a home page on the left. I'm not sure if that's 3.0 or iPhone specific as I never really moved left before.

It seems much harder to move apps screen to screen in 3.0. Not that its perfect in 2.2.1 either, but it is easier.
 

Duvi

Well-known member
Jun 17, 2008
2,063
18
0
Visit site
Also I sent 5 mms pics and noticed when I hit edit, it showed as though they sent 5 different messages. I'm going to call the person tomorrow and ask them how they came in.

They came as 5 different MMS. He was using an iPhone 2g on T-mobile using SwirlyMMS.
 

Duvi

Well-known member
Jun 17, 2008
2,063
18
0
Visit site
MMS is mostly completely missing from Rogers 3.0 installs I've seen. Didn't realize iPhone OS was customized to that degree by region?

Do you have MMS enabled on your account? If you put your sim in another device (that is capable), are you able to send one?
 

kevinwallace

Member
Apr 13, 2009
5
0
0
Visit site
I have MMS working but I did have to edit the carrier settings, even though I have a family plan At&t still insists on blocking MMS,All it took was a little convincing, I do get error from time to when sending. But other than that its working just fine.
 

Trending Posts

Members online

Forum statistics

Threads
259,710
Messages
1,764,129
Members
441,190
Latest member
Calion