1. Noonan's Avatar
    Hey Guys
    I have a 3GS. As soon as purplera1n came out back in July I jailbroke the phone. In the beginning of this month, I had a pixel out so I restored my iPhone back to the way it was.

    When I got the new iPhone, it already had 3.1 on it.

    How do I go about getting 3.0 onto my 3GS so I can jailbreak??
    08-25-2009 07:03 PM
  2. Alli's Avatar
    You sure it has 3.1 and not just 3.0.1? (3.1 hasn't been released yet.)

    And you can jailbreak on 3.0.1.
    08-25-2009 07:10 PM
  3. Noonan's Avatar
    Oh you're right. Its 3.0.1, I was thinking it was 3.1!

    Thanks!
    08-25-2009 07:26 PM
  4. Noonan's Avatar
    So, I used purplera1n.... :/

    What should I do? It shows Geo Holts or whoever it is, purplera1n says "Done! Wait...". Should I just unplug it and restore or should I wait?
    08-25-2009 07:37 PM
  5. Tramain's Avatar
    So, I used purplera1n.... :/

    What should I do? It shows Geo Holts or whoever it is, purplera1n says "Done! Wait...". Should I just unplug it and restore or should I wait?
    You cannot jailbreak iPhone 3.0.1 with purplera1n
    08-25-2009 07:38 PM
  6. Noonan's Avatar
    I know that now.. Thats why I am asking how should I get back to my backup!
    08-25-2009 07:40 PM
  7. Tramain's Avatar
    I know that now.. Thats why I am asking how should I get back to my backup!
    Restore as new and jailbreak with redsn0w.
    08-25-2009 07:44 PM
  8. Noonan's Avatar
    I didnt know if I could just unplug it from my computer while it still showed Geo on my iPhone, but I did it and its restoring fine.

    Thanks!
    08-25-2009 07:58 PM
  9. Dipstix6996's Avatar
    Im bringing this back from the dead because i have the same question.

    My phone froze and i could not turn it on. Consequently, i had to do a restore. When I did the restore it upgraded my firmware to 3.1.

    How do i get it back to 3.0 so i can jailbrake again!?!?!
    09-14-2009 10:04 PM
  10. tpierce67's Avatar
    As of right now you can't. Probably won't ever be able to downgrade back to 3.0. I'm in the same situation. Maybe the Dev team can pull a rabbit out their hat and make it happen......but as of right now it's not looking very promising.
    09-16-2009 09:30 AM
LINK TO POST COPIED TO CLIPBOARD