1. Vderks's Avatar
    I have a 2G model running the 2.2 update. I am unlocked and operating on T-mobile. Everything works as expected except it will not connect to the Internet with EDGE. For full exclosure, I'm not very techy and paid a guy to perform the unlocking. Because everything else works I think it a setting that needs adjusted. The guy at t-mobile (who does not have an iPhone) tried to help without succes.
    Thanks in advance,
    Vicki
    01-05-2009 03:35 AM
  2. Jeremy's Avatar
    First you need to make sure you have a data plan on T-Mobile. Then you need to go into the settings and change the APN Network setting to the following:

    User Name: wap.voicestream.net

    Password: Leave Blank
    01-05-2009 10:27 AM
  3. Vderks's Avatar
    Ash,
    Thanks for the reply. The nice fellow at the t-mobile store did that one only he was unsure. Bottom line-it didn't help. Any other suggestions?
    Vicki
    01-05-2009 02:37 PM
  4. JasontheGreat's Avatar
    First you need to make sure you have a data plan on T-Mobile. Then you need to go into the settings and change the APN Network setting to the following:

    User Name: wap.voicestream.net

    Password: Leave Blank
    Thanx!! Helped alot. Made my day
    01-05-2009 05:40 PM
LINK TO POST COPIED TO CLIPBOARD