1. john_v's Avatar
    So I had upgraded to Windows 10, then rolled back to 7. When I rolled back to 7, I could no longer get iTunes to update. I kept getting an error that "The feature you are trying to use is on a network resource that is unavailable." It was looking for the file "iTunes6464.msi" and no matter what I did, it would not locate it. I even used Tools>Download only in the Apple Software Updater, to where I had the actual iTunes6464.msi on my computer and it wouldn't recognize it.

    I didn't see anything here on iMore, but in an unrelated thread someone directed towards the Apple support forums, where I did find my answer. It solved my problem, and so I just wanted to share the links here in case someone is having the same problem. There's a little bit of registry editing, but it isn't hard even though it may seem a little intimidating. So if you're having this same problem with being unable to update due to a "missing msi file", read through the thread in the first link below, then read and follow the troubleshooting steps in the second link. It worked like a charm for me and now I have the latest iTunes installed and running fine.

    Hope this helps someone...felt so good to finally solve my problem that I just had to share. After all, that's what this community is about, right?


    ReanimationXP likes this.
    10-02-2015 09:09 AM
  2. List Walker's Avatar
    Hey bro, thanks for the links, finally solved the iTunes install error for myself as well. I would say the big takeaway for me was, that you need to open RegEdit and browse to HKEY_LOCAL_MACHINE\SOFTWARE\ Classes\Installer\Products\. Then put the focus at the top of that section, choose Edit | Find, set the checkboxes for Data only, and search for "itunes". That landed me at the key that was messing the install up. You Delete that key (the parent key that has the string of letters and numbers) and rerun the install and it freakin' works! : )
    john_v likes this.
    10-24-2015 06:34 PM
  3. ReanimationXP's Avatar
    Saved my *** as well, thank you I should have done this before googling really, but figured I'd find an answer faster this way. The user above has the correct instructions for finding and correcting the problem, with one exception - I would note that searching for iTunes64 or iTunes6464 depending which file the installer is asking for would be more accurate - just deleting things that say iTunes I would not recommend.

    I did a Find for iTunes6464.msi under HKEY_CLASSES_ROOT\Installer\Products, and then when found deleted its' parent folder ( \Products\bunch of random numbers and letters ), and that fixed the problem instantly.

    Thanks for the tip guys! Learn to code, Apple!
    john_v likes this.
    11-26-2015 09:42 PM
  4. Erhaldo's Avatar

    Thanks so much for sharing.
    It assisted me in finding a solution for the same problem.
    john_v likes this.
    06-25-2016 03:15 PM
  5. Tiffany3's Avatar
    I can't believe this worked! I have been fighting my PC for over 5 months, since the new windows 10 rolled out and your instructions worked like a charm after getting repeatedly blocked! Thank you!
    john_v likes this.
    10-09-2016 09:55 AM
  6. janosikfajtisko's Avatar
    Worked like dam!! lots kudos !!!!!!
    10-27-2016 04:13 PM

Similar Threads

  1. Is the iPhone 6s dual sim capable?
    By iMore Question in forum iPhone 6s
    Replies: 1
    Last Post: 10-05-2015, 03:19 PM
  2. Replies: 2
    Last Post: 10-03-2015, 03:02 PM
  3. Replies: 1
    Last Post: 10-02-2015, 09:34 PM
  4. What are the dimensions of the iPhone 6s?
    By iMore Question in forum iPhone 6s
    Replies: 1
    Last Post: 10-02-2015, 06:11 PM
  5. Drafts gains support for 3D Touch, adds keyboard shortcut list on iPad
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 10-02-2015, 09:00 AM