1. Vermillion's Avatar
    Can someone help me with this? Back when OS 3.1.3 was out, we were recommended to not update unless it was needed, so I didn't. I am not sure if it's because of that that iTunes thinks that 3.1.3 is the latest OS when iOS 4 has been out for a short while now. I really, really want to update now and have my iPhone unlocked.

    I have an iPhone 3G, 16 GB. As a sidequestion, I was wondering if there is a version of redsn0w to JB my iPhone 3G without having problems with the unlock and such.

    Thanks guys!

    PS: Sorry if this is the wrong forum. I didn't find one with the word "iTunes" on it.
    06-25-2010 05:27 PM
  2. california_matthew's Avatar
    Can someone help me with this? Back when OS 3.1.3 was out, we were recommended to not update unless it was needed, so I didn't. I am not sure if it's because of that that iTunes thinks that 3.1.3 is the latest OS when iOS 4 has been out for a short while now. I really, really want to update now and have my iPhone unlocked.

    I have an iPhone 3G, 16 GB. As a sidequestion, I was wondering if there is a version of redsn0w to JB my iPhone 3G without having problems with the unlock and such.

    Thanks guys!

    PS: Sorry if this is the wrong forum. I didn't find one with the word "iTunes" on it.
    Do you have the newest version of iTunes because thats the only reason I can see it wouldn't know about the update unless its a bug! If it is up to date then just restore it and it should download it but don't do it unless you have iTunes 9.2!
    Last edited by california_matthew; 06-25-2010 at 05:44 PM.
    06-25-2010 05:41 PM
  3. Vermillion's Avatar
    Yep, I have the latest version of iTunes.
    Not totally sure if I want to update to 3.1.3 since I just heard the sn0wbreeze JB method is very cool >.<.
    06-25-2010 05:46 PM
  4. Vermillion's Avatar
    Issue fixed. I just had to select "Download Now" when it asked me to download 3.1.3, but the next Window contained the specifications for iOS 4, so I'm guessing I'm currently downloading IOS 4. Thanks for the help.
    06-25-2010 06:03 PM
  5. california_matthew's Avatar
    Issue fixed. I just had to select "Download Now" when it asked me to download 3.1.3, but the next Window contained the specifications for iOS 4, so I'm guessing I'm currently downloading IOS 4. Thanks for the help.
    Oh I thought you had 3.1.3 installed already because there was a jailbreaking solution for it! Glad to help!
    06-25-2010 06:11 PM
  6. Mustang5Oh's Avatar
    yes you can JB 4.0 OS the 3G. I did and cracked it to allow for multitasking and wallpapers. beware of this as it will lag the phone!
    06-25-2010 06:27 PM
  7. california_matthew's Avatar
    haha I am just gonna use iOS for my 3Gs I only use my 3G to test new software on!
    06-25-2010 06:28 PM
LINK TO POST COPIED TO CLIPBOARD