1. insidecny's Avatar
    The same way you remove apps. You hold down any app in the multitask section and they will all start to wiggle. Simply click the - sign over the ones you want to remove.


    How do you close a window when you dont want it to multitask?

    I heard tap and hold the home button but, not working.
    06-22-2010 08:54 AM
  2. insidecny's Avatar
    I have noticed the same issues. The calendars are not being synced at all the right way. Could be a gmail issue but i doubt the timing of it.

    Besides that, I have not noticed too much. I have gone through pretty much every app and tried every new feature. I like it. I have noticed a couple of my games have crashed a few times, but could be resulting in memory issues when having too much running. Will keep testing...


    Bugs? Where to start. GMail has a big issue. It doesn't seem to want to sync itself properly with IMAP. I was selling some concert tickets and relied on my phone to get customers. Well, I received a couple, but the actual PC client had more emails than my phone. I missed out on several deals. The iPod app is also funky. I can browse through the catalog looking at what I may want to play and then exit. When I go back in at a later time, it says now playing and something I wasn't even looking at is paused. It doesn't make any sound, so that's good...
    06-22-2010 08:57 AM
  3. golionsgo's Avatar
    I have had relatively minor issues compared to others:

    1. So far only one app doesn't launch (iCup2010); it'll start, but about 3-5s into the load sequence it shuts down. In 3.1.3 it worked fine.

    2. One app (Lexeme) has some weird orientation issues (again, not present in 3.1.3). When loaded from portrait mode, the status bar (the thing at top with clock, battery, whatever... not sure of its proper name) appears at the bottom, upside down. Meanwhile, the rest of the app loads normally, complete with a grey space at the top for the status bar. (The bar covers part of the app at the bottom.) Rotating the iPhone and then returning it to portrait resolves this though.

    3. iBooks works for me, except that when I load the store I can only see free books from Gutenberg. When I click "Featured" it gives me a "Cannot connect to iTunes Store" error.

    Otherwise, it runs smoothly. One other minor change I noticed (a good thing, for me) was that my bluetooth headset now plays my ringtones in the earbud instead of the headset's default tone sequence for an incoming call.
    06-22-2010 09:04 AM
  4. gshindledecker's Avatar
    Navigon Panorama View 3D seems to be broken. Also, I noticed that it doesn't seem to run in the background when I have Pandora running in the foreground.
    06-22-2010 09:07 AM
  5. itsyours2's Avatar
    I'm in the same exact boat. Also wondering about the text message thing.



    If you have no data like myself and smileyboy ^ more than likely a clean restore (possibly from DFU mode) and NOT from a backup, should work for you.

    1st restore. I upgraded yesterday from a jailbroken 3.1.3. After the upgrade went smooth, I restored from a backup and half way through it said it couldn't add my 16+gb of music b/c there was only 1.82gb free... but the bar at the bottom showed 25gb free. Don't know what happened there but it failed miserably if I tried to sync again... errors similar to "device full" or "internal error".

    2nd restore. Worked fine again and I restored from a different backup. When it tried to sync my Apps it gave an error something along the lines of "Internal device error" and shut off. Fail again.

    3rd restore. Everything worked well and restored from a backup just fine... but like stated above from smileyboy - no data... Edge or 3G. Reset network settings multiple times, tried everything I could think of to no avail.

    4th restore. Restored from DFU mode this time. Restore worked fine and set up as a new iPhone. Everything worked fantastic - including Edge & 3G. In order to troubleshoot (and b/c I was curious) - I wanted to see if it was truly DFU mode that fixed it or if it was my backup that was corrupt from the start. So I chose to restore from a previous backup and now the phone has no data again. It will work on wifi though.

    So. After many hours of frustration I've come to the conclusion that it was most definitely was some sort of corruption in the backup file itself. Possibly due to the jailbreak corrupting the backup somehow?

    With that said, I'm trying to figure out the best way to go about "starting over" on a clean restore tonight. I currently do not sync contacts but I'm thinking the easiest would be to sync via Google Sync for contacts and then manually install my apps. The only app that has data that I DO NOT want to lose is 1Password - but I've backed that up (a few times, lol).

    What about text messages? I've literally got years of texts from maybe 30 people that I'd prefer to not lose. I'll have to Google a solution for that but if anyone has ideas, please let me know!

    I can say, after using 4.0 intermittently, it runs 100% smoother than 3.1.x did on my 3GS. I'm impressed again. If it's running this well on my 3GS I seriously cannot wait to see how the iPhone 4 will handle it.

    Thanks for reading my rant and please feel free to chime in with any ideas!
    'DFU mode' ?? Please explain!
    06-22-2010 09:09 AM
  6. vapor03's Avatar
    I didn't see this in the thread, but my phone is no longer "compatible" with my Sony dock music player/clock radio. I have not yet checked my car stereo.

    Anyone else having issues with "music docks"?
    06-22-2010 09:12 AM
  7. shawnrouse's Avatar
    My bugs so far:
    - It won't stream 3gp anymore?! Is anyone else having this issue?
    - Ever since I upgraded, I can't do a backup. I did a full restore, and it still doesn't work. I keep getting the message "iTunes could not back up the iPhone 'my Phone' because an error occurred."
    - Spent 30 minutes organizing icons into folders in iTunes. Told iTunes to sync, and it sync'ed the apps, but not the folders. Had to start over from scratch. This has happened *twice* so far.

    Overall, I'm happy with it but the bugs are annoying.
    06-22-2010 09:19 AM
  8. killingwthasmile's Avatar
    Something that happened to me this morning was when i turned my alarm off the "Click to return to call" bar appeared for a second and then went away.
    06-22-2010 09:21 AM
  9. Jkelly89's Avatar
    I don't know how many times each of u may sync your phone but if u do it frequently GREAT! I solved all of my issues by restoring the phone from a much earlier back up. Instead of using your two most recent backups try one from an earlier date when u get to the screen that asks u to restore as new phone or from a back click the down arrow ad select your favorable date. And presto. U should b on your way to a working phone and iOS4 with no issues and also tethering
    06-22-2010 09:35 AM
  10. pilotnh's Avatar
    The quantity and scope of these bugs is reminiscent of my days with the original Blackberry Storm that brought me to iPhone in the first place. It seems so "un-apple-like" to kick out an update with this many issues.
    06-22-2010 09:37 AM
  11. DataCentre's Avatar
    I didn't see this in the thread, but my phone is no longer "compatible" with my Sony dock music player/clock radio. I have not yet checked my car stereo.

    Anyone else having issues with "music docks"?
    Works just fine with my Sony Dream Machine.
    06-22-2010 09:44 AM
  12. lurchaddams's Avatar
    I didn't see this in the thread, but my phone is no longer "compatible" with my Sony dock music player/clock radio. I have not yet checked my car stereo.

    Anyone else having issues with "music docks"?
    Similar issue but not a "dock" per se.

    iOS 4 breaks USB-to-Car Audio connection.

    I have a Pioneer DEH-P5100UB that has worked flawlessly with iPhone 3G running 2.2.1 and with iPhone 3GS running 3.0, 3.1, 3.1.1, & 3.1.2. Yesterday, I upgraded to iOS 4. Now, I get "Not Compatible" or "Error - 19"(connection error). I did a bit of research and it seems that this is happening to both Kenwood and Pioneer units, maybe others as well.

    Now, I am stuck listening to radio. WTH? Thanks, Apple!
    06-22-2010 10:01 AM
  13. MaKin's Avatar
    Similar issue but not a "dock" per se.

    iOS 4 breaks USB-to-Car Audio connection.

    I have a Pioneer DEH-P5100UB that has worked flawlessly with iPhone 3G running 2.2.1 and with iPhone 3GS running 3.0, 3.1, 3.1.1, & 3.1.2. Yesterday, I upgraded to iOS 4. Now, I get "Not Compatible" or "Error - 19"(connection error). I did a bit of research and it seems that this is happening to both Kenwood and Pioneer units, maybe others as well.

    Now, I am stuck listening to radio. WTH? Thanks, Apple!
    I am having the same problem with an isimple i just had installed. Worked fine with 3.1.2, but now says it is not a compatible device. Anyone have a solution??
    06-22-2010 10:04 AM
  14. rotchcrocket04's Avatar
    'DFU mode' ?? Please explain!
    DFU mode is a type of way to restore without loading any of the OS. See this link for details and an explanation of how to enter/restore in DFU mode.
    06-22-2010 10:11 AM
  15. slalomskie's Avatar
    Anybody notice the updated Dragon dictation bug?

    When you edit with the key board you lose the ability to the short cut to e-mail, text message or copy to clipboard, as well as the red button to add more dictation to the message. (photo)
    06-22-2010 10:11 AM
  16. Bear207's Avatar
    Update was slow but smooth for me.
    Noticing a lag in the home button action and a serious loss in battery life vs pre-iOS 4.
    06-22-2010 10:13 AM
  17. evansc22's Avatar
    Similar issue but not a "dock" per se.

    iOS 4 breaks USB-to-Car Audio connection.

    I have a Pioneer DEH-P5100UB that has worked flawlessly with iPhone 3G running 2.2.1 and with iPhone 3GS running 3.0, 3.1, 3.1.1, & 3.1.2. Yesterday, I upgraded to iOS 4. Now, I get "Not Compatible" or "Error - 19"(connection error). I did a bit of research and it seems that this is happening to both Kenwood and Pioneer units, maybe others as well.

    Now, I am stuck listening to radio. WTH? Thanks, Apple!
    Glad you posted this. I can confirm that the same problem exists for the DEH-P3100UB. I'm getting a different error, though: "N/A USB"

    The manual says this:

    CAUSE: "The USB storage device connected to is not supported by this unit."
    ACTION: "Connect a USB storage device that is USB Mass Storage Class compliannt."

    So, did iOS4 somehow change the way the iPhone 3Gs reports its Mass Storage Class? I sure wish they'd fix this. I own two of these Pioneer units and now they're both not working properly!! Curse you APPLE!
    06-22-2010 10:13 AM
  18. evansc22's Avatar
    Update was slow but smooth for me.
    Noticing a lag in the home button action and a serious loss in battery life vs pre-iOS 4.
    I noticed the battery life issues right away as well. This may be completely unrelated, but the battery life SEEMS to have gotten better after letting the unit run all the way down a few times, and then fully charging. It probably has nothing to do with it, but it seems to be better. I sure hope something makes it better. As it stands now, I'll be lucky to get through half a day.
    06-22-2010 10:15 AM
  19. evansc22's Avatar
    I found a post on the Apple Forums...someone suggested a hard reset...

    I reset my phone (hold both buttons down until the phone goes off), and hooked it to my Pioneer head unit, and it works now. Seems strange...but I'll take it.

    ...as it relates to the Pioneer & Kenwood units not recognizing the device after the iOS4 upgrade....
    06-22-2010 10:40 AM
  20. mbartel500's Avatar
    Maybe a bug.....maybe not

    I have sent several PDFs to my email, but when I click on them, isn't iBooks supposed to load them up? I get no joy. I hope someone can give a detailed description of how they got a PDF from email to iBooks

    Thanks
    06-22-2010 10:44 AM
  21. bold move's Avatar
    it stopped sometime in the night - restarted this morning and then there were problems and it automatically begain reinstalling apps and music and video - took forever - 2.5 hours later still updating the email - all appears very slow.
    06-22-2010 10:46 AM
  22. omg_its_kerri's Avatar
    Just tested mine and it's working fine
    With two additional restores and re-installations of the new OS, my MMS is working fine. I did forget to un-jailbreak my phone before installing iOS 4 the first time, though, and i'm positive that had something to do with it (DUH).

    All is well now, though!
    06-22-2010 10:52 AM
  23. chris.mccullor's Avatar
    I need some help with the push Gmail on my phone. I have a black 3G 16GB iPhone. Please help. What do I do to make the push work on my phone? I've already deleted my account and re registered it on my phone.
    06-22-2010 10:59 AM
  24. EKK330's Avatar
    Tons of my apps keep crashing when opened
    06-22-2010 11:12 AM
  25. lurchaddams's Avatar
    I am having the same problem with an isimple i just had installed. Worked fine with 3.1.2, but now says it is not a compatible device. Anyone have a solution??
    I just put an iSimple in my girlfriend's Murano in May. I haven't tried it yet.

    CRAP!
    06-22-2010 11:12 AM
404 ... 56789 ...
LINK TO POST COPIED TO CLIPBOARD