1. jakej914's Avatar
    Just as iPhone OS 3.0 (as it was then known) was made for the 3GS, I believe iOS 4 was made for the 4. While it sucks for owners of older iPhones, it makes users that much more likely that they'll see the upgrade as worth it. It seems to me that Apple's business model kinda follows this pattern of making its own products obsolete (if only slightly so, as is the case for my 4 y.o. MBP).
    07-04-2010 08:23 PM
  2. kalafalas's Avatar
    I'm on the iPhone 4 and I'm getting all sorts of problems, and I didn't restore from a back up. The messages app is buggy to all he'll and unstable to the max, confused at placing the bubbles, in animations and otherwise, like when I pull up the keyboard or even just the app, I find myself force quitting it a lot. The problem gets much worse when I turn on character count. Also, the keyboard is having trouble recognizing the space bar sometimes, and sometimes just skips over keys I pressed. Also, waking it from sleep takes forever sometimes, up to 5 seconds, and sometimes more than one push. Also there is an annoying lag after typing in my passcode. Also, but I might just be imagining this one, my battery fauns much faster if I have orientation lock on. Also, unlike 3.0, it doesn't let me curse anymore, I'm back to saying "shot" and "duck". And everything just feels... Umpolised, not apple stable, there are little tiny problems everywhere that didn't exist in 3.1.3, witch was the most stable since 1.1.4. Apple, please fix these problems, it's like 2.0 all over again.
    Last edited by kalafalas; 07-05-2010 at 03:55 PM.
    07-05-2010 03:53 PM
  3. kalafalas's Avatar
    How do I downgrade to 3.1.3?
    You need your shsh on file with Cydia, then edit the hosts file for iTunes to use that instead of apple servers, and then find the 3.1.3 ipsw and restore to that, and then use irecovery to get past the baseband downgrade failure, and then use either iTunes or a jailbreak tool to activate. Google it for more step by step instructions, it's everywhere
    07-05-2010 04:00 PM
  4. sharky2006's Avatar
    my screen is unresponsive at times and the lock/power button is finicky, and my text message bubbles blend into the status bar on the top for a second when I send a message... anyone experience this?
    07-06-2010 01:08 AM
  5. radical24's Avatar
    i have issues connecting to my sound id510 bluetooth. the reception is horrid, even tho i have the latest firmware for the headset. it actually freezes my phone. sometimes apps just dissapear and i have to reinstall them.
    07-06-2010 02:37 PM
  6. Andre's Avatar
    i have a 3g and dont plan on upgrading until the Iphone gets 4g radios but now with the new os. The phone hangs up alot exp if streaming and I get a phone call or email. I really want to go back to ios3.x is there a way to do this? I think the phone lacks the hardware to run the new OS effectively.

    Also apps are taking along time to load

    Also keyboard is not as responsive i have to wait on the virtual keyboard to catch up to me.

    Any advice or can anyone point me to a place in the forums that I can get back to the way it was?

    Thanks

    Andre
    07-07-2010 09:23 AM
  7. ywirasin's Avatar
    I'm really surprised to keep having so many dropped calls. I work in Sunnyvale, smack dab in the middle of silicon valley and we're getting dropped. WHY?!?!??! Maybe too much tech in the area mixing up the signals
    07-07-2010 07:06 PM
  8. Jemjee's Avatar
    Seems to be a bug in Bluetooth audio for SMS and mail notifications and gps turn instructions (like with navigon and tomtom). When I use my headset for gps instructions, I only get art of the instructions. It's like by the time the phone creates the audio connection with he headset, the instructions are almost or already completed to where I only hear part of it. For SMS and mail alerts, I get nothing as the tone is super short and complete before the headset is connected. Did not used to be a problem for ios 3.1.2.

    Thanks,
    Alan
    I am having the same problem. Basically when I have my BT connected, the message notification sound tries to come through the headset (which is fine with me). I really liked this feature before the updrade. Now, by the time the phone connects with the headset the tone is over. What that means is that if I have my BT turned on and connected, I get no message notification at all, since the phone doesn't make any sound. I hope that any forthcoming updates fix this issue. However, I'm not going to hold my breath.
    07-08-2010 02:56 PM
  9. NannyMac09's Avatar
    I have a 64GB iPod Touch and I downloaded the new iTunes update and the new iOSX4. Most of my movies won't work even though I unsynced and resynced and then it took my pictures and threw them into 2 folders and they're all mixed up together. Other than that everything else works great.

    BTW, it took me 4.50 hours to download the updates onto my iPod. Is that a record for downloads? All my friends said theirs downloaded in 2 hours or less.
    07-08-2010 07:02 PM
  10. Zenbones's Avatar
    I've noticed a small but annoying problem with my iPhone 4...when I want to type a long dash, I've always taken these steps:

    1) press/hold 123 button
    2) slide to dash, wait for extra characters to appear
    3) slide to long dash, lift finger to insert and return to QWERTY keyboard

    Now, more often than not, the extra characters never appear if I "slide" my way to the small dash; they only show if I first switch to the punctuation keyboard by tapping the 123, NOT using the press/hold method.
    I have noticed the same annoying quirk. My wife's iphone 4 also will not perform the ol' slide and hold. However, interestingly, after initially performing the "slow" method of a few taps to get to a dash or, say, an ellipses, I am able to perform the quicker slide and hold keyboard feature for the remainder of the time I am typing an email. I wonder-- read as "hope"-- if Apple is aware of this . . .
    07-08-2010 09:06 PM
  11. petec2010's Avatar
    Same problem on my iPhone 3GS. Took me ages to find the problem. In the end i searched the iOS4 user manual for "shuffle" and found an answer for the iPhone.

    "From the Now Playing screen, tap the album cover.
    The repeat, Genius, and shuffle controls appear along with the scrubber bar..."

    This was set to shuffle songs!!!! I set it to play in order and all now works.
    Hope same works for you.

    Pete


    WOW. 34 pages and not one other person has this issue... hopefully that means I am missing something...

    iPod Touch, 32GB, 3rd Generation, 3.1.3 -> iOS4

    Music: Songs do not play in album order. They will ONLY play in random order. There is a greyed out "shuffle" button when viewing an album's song list... pressing it will cause the album to be played in random order. NOT pressing it and just using the PLAY button does the same thing. There seems to be NO way to just hear the songs in order. I checked in Settings, nothing there.

    I stopped Music from the little hidden window when you double click the Home button, rebooted and nothing. It is driving me crazy. I have an album I just want to listen to from beginning to end, in order and that ability is just gone.

    How do you get an album to just play in the regular song order of the album?

    I even tried making a playlist and adding only the album songs. Hitting play still plays the songs in random order the same as if using the shuffle button.

    Shake to shuffle is turned OFF. I can not find any other place where there is a box checked that says "Always play in shuffle mode". It's annoying enough that I would gladly go back to 3.13 if that was possible. There are no real benefits that I would choose over just being able to listen to an album NOT shuffled.

    .
    07-09-2010 09:01 AM
  12. slalomskie's Avatar
    All went well with my conversion to IOS4 until I tried to send an email. No parameters were changed, but I keep getting "The sender address email address was rejected by the server.

    This does not happen with other email accounts on the same server.

    toGeorge,

    did you find a solution to this problem. My 4 worked fine in the begining then I had to restore / rebuild then re sync and now I get your problem.

    I also get this on my 3gs that I did a RESET via the setting /general / reset way to clear all my data.

    each phone has it's own e-maill account but it is on the same server.

    I can get incoming mail just fine. It just wont' send and like you my settings havent changed.
    07-10-2010 01:53 AM
  13. BrandonB's Avatar
    I noticed this for the first time yesterday, I wanted to adjust the volume of the ringer but I was not able to do so. I did what I would normally do while viewing the home screen, and pressing the plus and then minus button on the side of the phone. This displayed on the screen the normal popup image of the speaker and volume indicators. But it was missing the "ringer" title at the top of the popup image. The same popup you get when in an app. The volume of the phone changed but the ringer did not. I proceeded to make adjustments in the settings, but ultimately had to restart phone. Wondering if this has something to with the multi-tasking of a recently used app. Has anyone else noticed this?
    07-10-2010 10:14 AM
  14. slalomskie's Avatar
    All went well with my conversion to IOS4 until I tried to send an email. No parameters were changed, but I keep getting "The sender address email address was rejected by the server.

    This does not happen with other email accounts on the same server.
    toGeorge, the new OS version requires both an outgoing and Incomcing password and user name. Previously the one did the trick.

    I updated both incoming and outgoing with the same pass code and it works now.
    07-10-2010 04:40 PM
  15. sharky2006's Avatar
    I have 3gs and posted on the previous page with some issues and today I got a no sim inserted message and reception issues... and was lagging... any suggestions?
    07-11-2010 01:17 AM
  16. 1SocialMedia's Avatar
    well the most common issue which i faced with iOS4 is their internet connectivity .....
    07-13-2010 03:36 AM
  17. iBoxtaboy's Avatar
    Is there any way to disable the multi-tasking feature of iOS4? My 3GS is so laggy in performance now that I made the update. I don't even use the multi-task feature, and have to go in just to close out all the apps so that the phone doesn't lag so much. This OS is not really good on the 3GS IMO.
    07-13-2010 01:08 PM
  18. pstmstr's Avatar
    when in standby mode, if I get a phone call, I can't swipe to answer, I have to tap on the screen, then swipe.
    07-15-2010 10:55 AM
  19. R-y-a-n's Avatar
    HELP!! Maybe this is already in another thread but I'm not taking hours to go through all of it...
    Problem with my IPhone 3GS after installing 4.0. The songs in the Ipod have disappeared. All the Artists are still there but in order for me to listen to all my music on shuffle, I need to run the songs list and press all songs then shuffle. With nothing in my songs list this is impossible. I can only click on one artist at a time and shuffle through all of their songs only. This is frustrating as I depend on my music every morning going into work on the bus! Is there an easy solution?
    Thanks
    07-15-2010 11:45 AM
  20. Alinka's Avatar
    I got a problem with mail app: messages in all my mail boxes (except gmail) became UNREAD and were redownloaded from server. I see this problem twice during two weeks.
    Whats happening? Anybody have the same?

    -------------------------------------------------------
    iNvasions game is just released
    07-16-2010 02:49 PM
  21. cognisense's Avatar
    The most bizarre bug I have seen: my iPod insists on turning back it's clock by 6 days, 9 hrs & 18 min. No kidding. Every time I set it's clock (using the Settings app -> General -> Date & Time) and exit the Settings app, all is well. *Then, magically and ever so irritatingly, something causes the time to be retarded by 6 days and a bit. The exact amount of hours and minutes is variable over the course of a dozen trials, but the number of days (roughly 6 1/2) is consistent.*

    I am not sure what is causing this. I am not attaching my iPod to my pc, so the problem is definitely local to the iPod. The bug occurs regardless of whether or not I am connected to a wifi signal.*

    I have noticed this occurring after running the Settings app, but others cause the bug as well. One way for sure to recreate the problem is to set the clock, exit to the home page, and then go right back into the General section of the Settings app. As soon as I enter this section, the clock screws up.

    Any ideas???

    Another bug comes from the Photos app. *Sometimes, after viewing a single photo from an album, the app's navigation gestures cease to function. The only way to regain control is to press the Home button and relaunch Photos.

    Yet another is in Stanza. Upon launching the app, it erroneously returns to the final page of my last read book - instead of the current page of the Now Reading book. This bug doesn't occur every time, but maybe 1 in 4.

    Bottom line - there are so many reported ios4 bugs that I have decided to revert to 3.1.3.

    Easy enough, right?

    Well, not so. My pc only has the .ipsw image for 4.0, and all of the links I've found on the web for iPod1,2_3.1.3_7E18_Restore.ipsw all result in 404s. Arrrgh!

    Does anyone have an .ipsw image for 3.1.3 that they would be willing to email to me - or alternatively, point me to an ftp server???

    Many thanks...
    07-17-2010 03:18 AM
  22. sbrianw's Avatar
    Sometimes when I'm trying to put apps in folders, even though the folder isn't full, it won't let me put the app in the folder - it slides out from under the app as I try to drag and drop! Finally after some prodding I can get it to go into the folder.

    Another issue - before I got my iPhone 4, I had updated my 3GS with iOS4. My iPod application stopped working completely. When I would open it, it would crash. Repeatedly. Finally, I sync'ed it with my macbook again, and then no more iPod crashing problem. It was the weirdest thing ever.
    07-17-2010 01:31 PM
  23. lungho's Avatar
    I've only had this happen to me once but...... When I try to answer a call, the slide to unlock button sticks. I had to keep sliding my thumb across the screen multiple times before the slider finally stopped sticking and let me answer the call.
    07-17-2010 04:36 PM
  24. cognisense's Avatar
    I have never before saved my SHSH - and am now running ios4 - does this mean that I can no longer revert to ios 3,1,3???
    07-19-2010 03:54 AM
  25. jerrydavid's Avatar
    oh, not yet. I will come here later.
    07-19-2010 04:01 AM
404 ... 1314151617
LINK TO POST COPIED TO CLIPBOARD