1. Tunnelrunner's Avatar
    Mr P,

    That's a tough compromise...I'd hate to see the iPhone lose it's sleek, sexy look -- OTOH, improved battery life would be pretty sweet.

    I don't know a thing about science but I just don't think the technology is there yet for making a battery that's both tiny AND efficient. Just my 2 cents.
    11-30-2008 08:13 AM
  2. JustinHorn's Avatar
    Mr P,

    That's a tough compromise...I'd hate to see the iPhone lose it's sleek, sexy look -- OTOH, improved battery life would be pretty sweet.

    I don't know a thing about science but I just don't think the technology is there yet for making a battery that's both tiny AND efficient. Just my 2 cents.
    New battery technologies are right around the corner, maybe as soon as next year.
    11-30-2008 03:39 PM
  3. Tunnelrunner's Avatar
    Dizzy, that's sweet news. Here's hoping for iPhone III to come loaded with new features, improved battery life AND Razr like thinness?!

    BTW, on the topic of batteries, how's the Mophie working for you?
    11-30-2008 04:12 PM
  4. JustinHorn's Avatar
    BTW, on the topic of batteries, how's the Mophie working for you?
    It's working great! I'm about 80% of the way through writing up my review for my when will apple blog, just been delayed due to thanksgiving. Hopefully I can get it wrapped up later tonight.
    11-30-2008 04:20 PM
  5. MrP's Avatar
    Yipee!!! Woohoo!!!
    11-30-2008 04:25 PM
  6. MrEClass's Avatar
    @dizzy: Glad you got your phone up and working again! My pride is too big to swallow whole

    If you have jailbroken phone you can use AptBackup on Cydia to backup your apps.
    12-01-2008 12:48 PM
  7. rfg17's Avatar
    Every time I've had this happen, it's been because Mail.app has been spinning in the background trying to update. After I kill the app (by pressing and holding the home button), the battery drain stops. This is independent of FW version (i.e., happened on both 2.1 and 2.2).
    12-01-2008 01:01 PM
  8. MrEClass's Avatar
    Wow I have not had that happen before. When you opened the Mail app was the update icon spinner thing at the bottom constantly rotating?
    12-01-2008 01:07 PM
  9. rfg17's Avatar
    "Wow I have not had that happen before. When you opened the Mail app was the update icon spinner thing at the bottom constantly rotating?"

    Yes.
    12-01-2008 01:55 PM
  10. KStewart's Avatar
    I have noticed substantial battery loss, but I think it's due to the isolated issue with fetch email, correct me if I am wrong, but with 2.1 my web based mail account only fetched when the phone was active. Now with 2.2 it fetched as scheduled when the phone is in use or not like it should which is killing the battery faster.
    12-02-2008 04:43 PM
  11. JustinHorn's Avatar
    I have noticed substantial battery loss, but I think it's due to the isolated issue with fetch email, correct me if I am wrong, but with 2.1 my web based mail account only fetched when the phone was active. Now with 2.2 it fetched as scheduled when the phone is in use or not like it should which is killing the battery faster.
    If you didn't do fetch in 2.1 and just check webmail on safari and now on 2.2 you are using the mail app with auto fetch every 15 mins you will use the battery faster.

    My issue wasn't just using more battery than normal, but just absurd like 2 hours of standby bringing the battery to 70%. Plus my phone showed more usage than it should have instead of standby.
    12-02-2008 04:50 PM
  12. KStewart's Avatar
    If you didn't do fetch in 2.1 and just check webmail on safari and now on 2.2 you are using the mail app with auto fetch every 15 mins you will use the battery faster.

    My issue wasn't just using more battery than normal, but just absurd like 2 hours of standby bringing the battery to 70%. Plus my phone showed more usage than it should have instead of standby.
    15 min fetch has been the same 2.1 and 2.2. The only inconsistant thing has been battery life. Your battery problem seems both different and worse and like I said, it fetches consistantly now with the same 15 minute setting, where as before with 2.1 it wouldn't connect until I woke the phone and if I stayed on the phone for more than 15 minutes then it would sync, but when the phone wasn't active I would intermitantly get 15 min fetches, mostly edging towards not, now with 2.2 it fetched consistantly hence the battery drain.
    12-02-2008 06:32 PM
  13. JustinHorn's Avatar
    15 min fetch has been the same 2.1 and 2.2. The only inconsistant thing has been battery life. Your battery problem seems both different and worse and like I said, it fetches consistantly now with the same 15 minute setting, where as before with 2.1 it wouldn't connect until I woke the phone and if I stayed on the phone for more than 15 minutes then it would sync, but when the phone wasn't active I would intermitantly get 15 min fetches, mostly edging towards not, now with 2.2 it fetched consistantly hence the battery drain.
    I would delete add the mail account back. This may have been the source of my problem, I'm not sure. If the mail account delete / add doesn't work you might need to do a restore.
    12-02-2008 07:17 PM
  14. KStewart's Avatar
    I would delete add the mail account back. This may have been the source of my problem, I'm not sure. If the mail account delete / add doesn't work you might need to do a restore.
    I posted in reference to a trend with this thread. My noticable battery loss isn't significant enought to merit a problem. I am actually fine with battery performance...no need to reset my account, no need for hard resets or restores.
    12-02-2008 08:39 PM
  15. JustinHorn's Avatar
    Ok, well I started this thread about a significant battery problem so I guess that is where the confusion was. Glad to hear your phone is working normal.
    12-02-2008 08:43 PM
  16. KStewart's Avatar
    Ok, well I started this thread about a significant battery problem so I guess that is where the confusion was. Glad to hear your phone is working normal.
    No problem...and my phone isn't quite normal. I just wanted to add that there was battery loss for me with 2.2.
    12-02-2008 08:54 PM
  17. wabbit#IM's Avatar
    Wabbit,

    You were able to go 2 days before recharging??? I've always had to charge at least 1-2 times per day, which I think is pretty typical of all 3G phones and moderate use.

    Personally, I think lasting 2 days might have been a bug in itself...

    i was avg 36 hrs, with web browsing / email / phone. basically from 1 morning to the next day bed time i would actually charge it or it need one.

    the phone runs hot now, i can feel it through my case, which i never did, i did do a restore, the other memory went down from 350 megs to 230ish or about off the top of my head, the phone still runs hot, and gets about 6 hrs of battery life. its all firmware. 2.1 worked fine, 2.0.2 worked fine.
    12-02-2008 10:30 PM
  18. aetilden's Avatar
    Read a post that said Push Exchange email was always on and he deleted the account and reset and that worked - really improved battery life. I don't have Push Exchange, but found out I had Push MobileMe email on. Since I turned that off battery life has really improved. Getting my email updated every 15-minutes is fast enough for me.
    12-03-2008 06:11 AM
  19. aetilden's Avatar
    Read a post that said Push Exchange email was always on and he deleted the account, renetered it and reset and that worked - really improved battery life. I don't have Push Exchange, but found out I had Push MobileMe email on. Since I turned that off battery life has really improved. Getting my email updated every 15-minutes is fast enough for me.
    12-03-2008 06:14 AM
  20. BB-fan's Avatar
    Mine holds really well until about 50 percent battery life, after that it drains so fast that within an hour I can be in 20 percent just on stand by. Its happened to me 2 or 3 times in the last couple of weeks. Sometimes I think its the internet trying to load a page. I can click safari and its finishing loading a web page.
    12-03-2008 10:10 AM
  21. BB-fan's Avatar
    Oh ya I forgot, I often charge it in the morning for the new day ahead and I can have 60 percent life when I do so. Is this bad? Is it like a laptop battery where you should let it fully drain before charging it?
    12-03-2008 10:14 AM
  22. JustinHorn's Avatar
    Mine holds really well until about 50 percent battery life, after that it drains so fast that within an hour I can be in 20 percent just on stand by. Its happened to me 2 or 3 times in the last couple of weeks. Sometimes I think its the internet trying to load a page. I can click safari and its finishing loading a web page.
    I think part of this is just the way the battery functions. It will take longer to get from 100% to 50% than 50% to 0%. Just like when you are charging it takes longer to charge that last little bit. You can be at 20% and within 30 mins you will jump up a lot, but to get back to 100% takes time. Mainly from like 80% to 100%. I kind of think about it as filling a balloon with air. It's really easy to start filling it up, but as you try to make it more and more full it's harder.
    12-03-2008 10:23 AM
  23. wabbit#IM's Avatar
    Read a post that said Push Exchange email was always on and he deleted the account and reset and that worked - really improved battery life. I don't have Push Exchange, but found out I had Push MobileMe email on. Since I turned that off battery life has really improved. Getting my email updated every 15-minutes is fast enough for me.
    I do not use an exchange server. All my emails are setup as IMAP.
    12-03-2008 12:38 PM
  24. BB-fan's Avatar
    Ok its official by battery is like fried or something. I used to go two days without a charge now I can't get 6 hours. With little use mostly standby. I am getting annoyed big time.
    12-04-2008 03:56 PM
  25. BB-fan's Avatar
    Found it seems to be email getting hung up or stuck in the connecting mode sometimes so its like constantly checking the servers. I have both an exchange account on it and another regular account set on fetch for every hour. Seems like 2.2 caused a problem with this. All was fine in 2.1.
    12-10-2008 10:28 AM
52 123
LINK TO POST COPIED TO CLIPBOARD