1. SirBert's Avatar
    I got a 3GS last August and Jailbroke it to version 3.0.1, it's remained that way since and has worked fine. Last week, the battery performance nosedived to the point that the phone lasts about an hour now on standby before dieing, it then takes about half hour in a charger before showing any signs of life.
    I've heard that a Restore might be the next thing to try before taking it back to the place I got it from (obviously un-jailbreaking it first).

    When I tried to Restore using my 3.0.1 IPSW file via iTunes it came up and said something about unable to verify device (sorry, I should of made a note of the exact error), googling the error it seemed that the Restore was contacting Apple to verify it, Apple wasn't verifying the Restore and was coming up with the error.
    I then placed the following in my Hosts file so that the Restore got fooled into going to Sauriks server: gs.apple.com

    I have SHSH files at Sauriks server for 3.1, 3.1.2 & 3.1.3 but I don't think Saurik stores 3.0.1 SHSH files so I assume this is where my problem lies ?

    I'm not sure what to try next, would I be best off getting a custom 3.1 IPSW file and Restore using that ?

    04-26-2010 02:28 AM
  2. big9erfan's Avatar
    It all depends on what you need out of your jailbreak.

    Since you have your SHSHs on file you have a lot of options. Personally I would install 3.1.2 ( make sure you leave your host file modified ), then test your battery and see how it works out for you. If you still have problems you're going to lose your jailbreak when Apple gives you a new device.

    If your battery is fine after that you can use blackra1n to jailbreak and then if you want use something like sn0wbreeze to update to a custom 3.1.3 to preserve your jailbreak.
    04-26-2010 11:05 AM
  3. SirBert's Avatar
    Thanks mate. Not sure but I may have fixed it now, found an article that mentioned deleting mail accounts (only had a POP3 account, not an Exchange one though that apparently can cause this problem, still deleted the POP3 account anyway) and resetting network settings. After a couple of soft resets and more charging the battery seems to be holding the charge a lot better.
    Based on your advice though I'll look into going to 3.1.2 if I experience any more problems, I was hoping to wait off from upgrading it till OS4 made an appearance and got broken.
    Thanks again.
    04-27-2010 02:13 AM