1. Rambo64's Avatar
    Hi. First off all, I want to say. My english is bad soo forgive me.
    Here is the thing I want to talk about, and ask for help..

    3 days ago, i bought a "iPod touch 8GB". When I came home I wanted to jailbreak it.
    I installed iTunes and then I updated my iPod to the lastest version, which is 3.1.3. Then my friend sayed "You cannot jailbreak it with this version. You must ungrade(update to the older version) wich is: 3.1.2.
    So he gived me this site for the 3.1.2 version downloading: iPod, iPhone and iPad Firmware Download
    So I downloaded that version: iPod touch 2G (3.1.2/7D11) and ungrade the iPod to older version (3.1.2).
    I did this ungrade like this: I pressed the Shift and klicked on Restore and I taked the older version (3.1.2).
    Then after that he said that I must have an other program to do this jailbreak. So he gave me this site: blackweather And I downloaded it.

    I watched the tutorials on youtube and I did exactly some thing they are doing on the video. I did it meny times and I watched also other videos. I did it like them.
    BUT, after I have jailbreaked the iPod and when Im finished I tested to POWER OF the iPod and POWERED it again. So I gett a screen like this:
    I did the jailbreak many times but the result is same.

    I did many things. I hold the home and power button. I watcher many videons on youtube and ITS IS THE SAME RESULT..

    What can I do. Help me..

    I also tried other jailbreakes like, REDSN0W, Pwnagetool.
    The last thing I watched and tested is:

    What can I do.. Pleace help me..

    Thanks // Rambo
    04-17-2010 05:51 PM