AirPods Pro deal at Amazon: Save $52 for a limited time!

  1. sanctifi3d's Avatar
    Hi I'm having a problem I just restored my phone and only installed openssh,sbsettings, and some apt 0.7 update. I restored because of this ssh problem.. and it's back again

    my problem is after installng openssh I can use ssh for about <10 mins then it disconnects.. After that I can't connect anymore it gives me this error:

    ssh_exchange_identification: connection closed by remote host
    it only works again after I reinstall openssh and openssl, but always disconnect after <10mins then back with the problem again.. I tried restoring a few times only installing sb settings and openssh(w/ openssl) then the other "essential upgrades" I already tried to remove known_hosts,check allow.hosts and deny.hosts, restores,etc I tried a whole lot of things with help from other people too I just cant make it work please help me I'm out of ideas/options

    I have an Iphone 3g 3.1.2
    03-08-2010 07:39 PM
  2. en0c's Avatar
    Set the automatic lock to "Never" and you should be fine.
    03-10-2010 04:43 AM
  3. sanctifi3d's Avatar
    did that already it doesn't affect it
    03-10-2010 06:32 AM
  4. sanctifi3d's Avatar
    any more suggestions?
    03-10-2010 12:34 PM
  5. antoniomax's Avatar
    I'm with the exact same issue here, please help
    03-11-2010 12:16 PM
  6. sanctifi3d's Avatar
    I found a temporary solution... Downgrade to 3.1 it works for me atm I'll report if it fails. try it
    03-11-2010 06:04 PM
  7. sanctifi3d's Avatar
    awww it's back again . something is REALLY messed up
    03-11-2010 08:50 PM
  8. sanctifi3d's Avatar
    serious issue still no fix.. I hope someone can figure out what's wrong with this.

    i use a temporary fix though.. it'll buy you a few mins with ssh then disconnect

    make a new file called ""
    put this inside
    rm ~/.ssh
    rm -rf /etc/ssh
    apt-get install --reinstall openssh
    apt-get install --reinstall openssl
    then transfer that to /var/mobile(using diskaid or total commander or iphonebrowser)

    open mobileterminal on your iphone(download in cydia if you don't have it)
    run the following commands
    > su [enter]
    > alpine [enter] (or if you set another password use that)
    > chmod 0755 [enter]
    > ./ [enter]
    > respring [enter]

    what it does is it deletes ssh folders(including those keys) and reinstall openssh and openssl.

    only works for a few mins though then you'll get disconnected again.
    Last edited by sanctifi3d; 03-12-2010 at 11:19 AM.
    03-12-2010 11:16 AM
  9. antoniomax's Avatar
    This is the best solution so far, it works, but just for a bit as sanctifi3d said.
    There's any nix masters to give us a little hand here?
    03-15-2010 09:49 AM
  10. sanctifi3d's Avatar
    antoniomax still got that problem? I got mine fixed by following this...

    I followed both then just restart and reinstall openssh and openssl
    you can use ifile to delete the files I think it's faster that way.
    follow the instructions below :-

    * Variants A-C Follow these steps

    1. First Change your root password (Link)
    2. Now, will start deleting bunch of virus effected files..
    3. Type “rm /var/mobile/Library/LockBackground.jpg” and hit return- With out “s
    4. “rm /System/Library/LaunchDaemons/com.ikey.bbot.plist” and hit return
    5. “rm /bin/poc-bbot” and hit return
    6. “rm /bin/sshpass” and hit return
    7. “rm /var/log/youcanbeclosertogod.jpg” and hit return
    8. Now, close Terminal app.
    9. Select your favorite wallpaper and reboot your iPhone.

    * Variant D – Follow these steps

    1. First Change your root password (Follow Answer 2).
    2. Now, will start deleting bunch of virus effected files..
    3. “rm /usr/libexec/cydia/startup” and hit return
    4. “rm /usr/libexec/cydia/” and hit return
    5. “rm /usr/libexec/cydia/startup-helper” and hit return
    6. “rm /System/Library/LaunchDaemons/com.saurik.Cydia.Startup.plist” and hit return
    7. Now, close Terminal app.
    8. Reboot your iPhone.
    ****If you got effected with Variant D. You need to reinstall

    what i dont understand is how come I got the error after a restore.. anyways it's fixed so yeah just do the steps above even after a restore dunno why but I think its the bbot thinggy
    03-16-2010 09:44 AM