1. Balzorosso's Avatar
    Hi buddies,

    writing from china (but I'm italian). I tried to upgrade to 3.0 my iphone 2G edge (bought last year in US) but after following the correct stated procedure, redsnow takes a nap on "waiting for reboot". Progress indicator bar doesn't take any step, and I can only click on "cancel" button to quit redsnow, and then press power+home buttons on iphone to reboot it.
    Iphone is locked right now, emergency calls only.

    I'm running redsnow on a Mac OSX 10.5
    Itunes 8.2

    I downloaded the IPSW firmware from here: ihackintosh.com/2009/06/download-os-30-software-update-for-iphone-2g-3g/]DownloadOS 3.0 Software Update for iPhone 2G, 3G | Apple
    (obviously I downloaded the 2G one)

    Any hints?
    09-03-2009 02:52 AM
  2. Balzorosso's Avatar
    Auto-Solved. Actually, when you get stuck on "waiting for reboot" message, you only need to unplug the usb cable and then plug it in again.. =_=

    Thanx anyway...
    09-03-2009 01:18 PM
  3. Skywalker's Avatar
    I agree with Balzorosso.
    09-03-2009 04:07 PM