1. BrockS.'s Avatar
    Hi, I'm new to Apple after having Blackberries for the last few years. Like it so far but have a problem that can very well be a deal breaker. My business email account will not send emails from the phone. I get a message stating that the email could not be sent because the recipient's "server does not allow relaying". However, should I send an email to the same address through my personal account, no problems. I did not have this issue with BB, so I'm wondering if I need to change some settings somewhere. I do not have any problems receiving messages. The only difference between the two in that regard is my business account has to "fetch" while Yahoo will push. My business account is through Compuserve (AOL) and personal is with Yahoo. Any help given would be greatly appreciated.

    Hope I posted in the right place. Thanks in advance.

    Edit: I did search but didn't come across anything. Also, I'm running iOS5 on a Sprint iPhone 4
    11-07-2011 12:54 PM
  2. Alli's Avatar
    Make sure you have the correct smtp settings for your work account. You'll get that error message if you are replying from one email address, but using the smtp belonging to a different account.
    BrockS. likes this.
    11-07-2011 01:44 PM
  3. BrockS.'s Avatar
    Make sure you have the correct smtp settings for your work account. You'll get that error message if you are replying from one email address, but using the smtp belonging to a different account.
    Thank you, I'll check that now.
    11-07-2011 02:27 PM
  4. BrockS.'s Avatar
    I've checked the settings, which were wrong, however, I'm still getting the same message: "The recipient [insert contact] was rejected by the server because it does not allow relaying" Any other suggestions?
    11-07-2011 02:53 PM
  5. lv1's Avatar
    I've checked the settings, which were wrong, however, I'm still getting the same message: "The recipient [insert contact] was rejected by the server because it does not allow relaying" Any other suggestions?
    ISP's do this to prevent spam. I had this type of message on all my devices from time to time. Not specific IPhone issue. In the outgoing mails server settings, make sure you have the correct SMTP.. set. Type in your user name and password and for authentication set "password". Also make sure SSL is set for off. That works for me on my POP accounts. Let us know if it works.
    BrockS. likes this.
    11-07-2011 03:21 PM
  6. BrockS.'s Avatar
    Thank you for the explanation. Entering the password and username in the settings fixed everything. Since "optional" was present under those two areas int the SMTP settings, I did not think it required.
    11-07-2011 03:29 PM
  7. lv1's Avatar
    Thank you for the explanation. Entering the password and username in the settings fixed everything. Since "optional" was present under those two areas int the SMTP settings, I did not think it required.
    Glad that it helped. I came from the BB Storm to the IPhone in February and I love it. Best of luck to you.
    11-07-2011 03:39 PM
  8. noaim's Avatar
    Thank you for the explanation. Entering the password and username in the settings fixed everything. Since "optional" was present under those two areas int the SMTP settings, I did not think it required.
    Happy to see you got this worked out.. emails settings can be some of the most finicky things out there...
    11-07-2011 06:29 PM
  9. takeshi's Avatar
    I've checked the settings, which were wrong, however, I'm still getting the same message: "The recipient [insert contact] was rejected by the server because it does not allow relaying"
    Thank you for the explanation. Entering the password and username in the settings fixed everything. Since "optional" was present under those two areas int the SMTP settings, I did not think it required.
    Relaying is the keyword here. It means that you need to authenticate to the SMTP server (if that's an option with your email provider) to use it.

    I did not have this issue with BB
    BB's don't always use your email provider's SMTP servers.
    Last edited by briareus; 11-07-2011 at 11:40 PM.
    11-07-2011 11:37 PM
  10. David Clemens's Avatar
    I received the same error message when I tried to send email from my iPod. I could send email from my primary email account, but any mail sent from a secondary account would just sit in my out box.
    Here is the fix I used: Go to Settings, then Mail, Contacts, Calendars. Tap on the name of the primary email account. Then tap on Add Another Email... Type in the name of the secondary email account. Tap Return, then tap <Back.
    Your secondary email will be added and you will be able to send email.
    06-26-2015 12:09 AM
  11. HankAZ's Avatar
    I received the same error message when I tried to send email from my iPod. I could send email from my primary email account, but any mail sent from a secondary account would just sit in my out box.
    Here is the fix I used: Go to Settings, then Mail, Contacts, Calendars. Tap on the name of the primary email account. Then tap on Add Another Email... Type in the name of the secondary email account. Tap Return, then tap <Back.
    Your secondary email will be added and you will be able to send email.
    Wow... apparently people don't bother to check to see that a thread has laid dormant for THREE AND A HALF YEARS before chiming in the the "fix". How do they even find threads that old?
    06-26-2015 12:50 AM
LINK TO POST COPIED TO CLIPBOARD