1. jkk4_1998's Avatar
    Hi, I've got a contact list from work on my iPhone 5 and it doesn't seem to save to iCloud. When I go to the iCloud site, it only lists some of my personal contacts, roughly 20. Am I missing something here? How to save ALL my contacts into iCloud. Any help would be appreciated.

    Thanks

    jkk4
    11-26-2013 06:59 PM
  2. John Yester's Avatar
    Those work contacts are getting pulled from that server. Best way is to export them and import them to iCloud
    11-26-2013 07:31 PM
  3. iHackPro's Avatar
    Does your Settings-iCloud for Contacts look like this?

    How to save ALL my contacts into iCloud?-image.png
    11-26-2013 07:32 PM
  4. jkk4_1998's Avatar
    Does your Settings-iCloud for Contacts look like this?

    Click image for larger version. 

Name:	image.png 
Views:	126 
Size:	128.0 KB 
ID:	43222
    Yes, looks exactly like this. Also, to John, how would I export those contacts from my company server? FYI, If I delete my company email address, then my contacts go away, so you are right about them residing on the company server.
    11-27-2013 06:21 AM
  5. Not Quite Right's Avatar
    Yes, looks exactly like this. Also, to John, how would I export those contacts from my company server? FYI, If I delete my company email address, then my contacts go away, so you are right about them residing on the company server.
    Export the list as a Vcard and import that file into iCloud ...
    John Yester likes this.
    11-27-2013 11:19 AM
  6. ritesh's Avatar
    When you open your contacts tab, do you see something called GROUPS on top left? If yes follow below.

    Check Settings>Mail, contacts, calendar> scroll down to contacts> ( There is Sort Order, Display order, short name, My info) do you see one more field called "default contact group" or "Save contact to"? This is the main culprit for your manually added contacts not saving to icloud but some other group.

    If you do: open contacts again> Groups> uncheck icloud contacts. See how many contact are other than icloud. If list is small, write them on a piece of paper ( else export vcard 1 by 1 as email to icloud email) and delete them one by one.
    Then go to settings>icloud>switch off contacts from icloud sync.

    Go to contacts tab again and check if your contact list is clear.

    Once clear, uncheck contacts sync from Facebook setting too. ( Settings> scroll down to facebook and turn off Contacts tab there).

    After this, restart your phone and see if contact list is still clear.
    Then turn on your contacts sync from icloud setting.
    Twist the Leaf and Quamrul like this.
    12-09-2013 02:48 AM
  7. Twist the Leaf's Avatar
    Thank you ritesh! You're a lifesaver.
    ritesh likes this.
    06-07-2014 01:29 AM
  8. Itamar Huli's Avatar
    Great great
    Many thanks!!!
    06-19-2014 04:48 AM
  9. Fedja Kapetanovic's Avatar
    Hello,

    I tried this but list nothing worked for me. My problem is that all of my contacts are in my phone and just a few of them in iCloud, I don't know why iCloud choose just those contacts to copy but I want them all in iCloud and I don't know how to do that. I do all possible sync and everything works but contacts sync.

    I would appreciate any help
    10-21-2014 07:20 AM
  10. Delumination's Avatar
    Hey Fedja,

    Just go to Settings -> iCloud, turn off Contacts sync and turn it on again. That's all. Works on iOS 8.
    12-29-2014 04:35 PM
  11. Jennnnnn's Avatar
    I finally figured it out!!!! YOU DO NOT HAVE TO EXPORT/ OR WRITE DOWN EVERY CONTACT INDIVIDUALLY.

    I'm assuming you have all your accounts synced up with your iPhone but your problem is that you want all your contacts from one email address to show up under your iCloud. It is possible to get all the contacts into your iCloud; however going forward you will have to set your default to iCloud. It may be possibly but I have not discovered a way to keep all contacts across multiple email addresses all syncing with each other.

    On your computer open contacts-> on top left select "contacts"-> Accounts -> Click the account you wish to move the contacts from and make sure contacts is checked.

    Then...

    Go back to contacts and select contacts under the account you wish to transfer from. This will show the contacts stored only on that account. Select one of the contacts in the list (it will turn blue) -> use command+A to select all the contacts -> two finger click and select "export v card" and save it somewhere on your computer.

    Then...

    on the left select the account you want to transfer to (your iCloud account). On the top left click File -> Import -> select the card file that you just saved and that should transfer them all in and alert you if there are any duplicates that you are attempting to transfer in. =)

    Remember to change the settings on your phone so that all new contacts you put in are saved to your iCloud account (on phone: Settings-> Mail, Contacts, Calendars -> Scroll to choices listed under "contacts"->Default Account-> Select iCloud.

    Hope this helps!
    01-21-2015 06:12 PM
  12. Joey Stever's Avatar
    I can't find the accounts under contacts
    04-06-2015 07:50 PM
  13. Ledsteplin's Avatar
    I can't find the accounts under contacts
    Does turning contacts on in Settings >iCloud <toggle contacts on not work for the contacts? Did you try the "off, then back on"?


    Sent from my ancient but trustworthy iPhone 5. ☮
    04-06-2015 10:43 PM
  14. Michael Maitlen's Avatar
    Ritesh,

    Do you know how to do these on the latest versions? I no longer see the option "Default Groups"... Just Sort Order, Display Order, Show in App Switcher, Short Name, and My Info...

    Thanks!

    Mike
    04-21-2015 06:46 PM
  15. Michael Maitlen's Avatar
    Jennnnn,

    Killer job! I've been working on this for hours today! I thought since everything was "synced" in iCloud that my contacts should be under the "iCloud" group but manually adding them makes sense too - just wish it was more intuitive. Thanks!!!

    Mike
    04-21-2015 07:20 PM
  16. Michael Maitlen's Avatar
    Jennnnn,

    Killer job! I've been working on this for hours today! I thought since everything was "synced" in iCloud that my contacts should be under the "iCloud" group but manually adding them makes sense too - just wish it was more intuitive. Thanks!!!

    Mike

    I finally figured it out!!!! YOU DO NOT HAVE TO EXPORT/ OR WRITE DOWN EVERY CONTACT INDIVIDUALLY.

    I'm assuming you have all your accounts synced up with your iPhone but your problem is that you want all your contacts from one email address to show up under your iCloud. It is possible to get all the contacts into your iCloud; however going forward you will have to set your default to iCloud. It may be possibly but I have not discovered a way to keep all contacts across multiple email addresses all syncing with each other.

    On your computer open contacts-> on top left select "contacts"-> Accounts -> Click the account you wish to move the contacts from and make sure contacts is checked.

    Then...

    Go back to contacts and select contacts under the account you wish to transfer from. This will show the contacts stored only on that account. Select one of the contacts in the list (it will turn blue) -> use command+A to select all the contacts -> two finger click and select "export v card" and save it somewhere on your computer.

    Then...

    on the left select the account you want to transfer to (your iCloud account). On the top left click File -> Import -> select the card file that you just saved and that should transfer them all in and alert you if there are any duplicates that you are attempting to transfer in. =)

    Remember to change the settings on your phone so that all new contacts you put in are saved to your iCloud account (on phone: Settings-> Mail, Contacts, Calendars -> Scroll to choices listed under "contacts"->Default Account-> Select iCloud.

    Hope this helps!
    04-21-2015 07:25 PM
  17. vmzi's Avatar
    Hey Fedja,

    Just go to Settings -> iCloud, turn off Contacts sync and turn it on again. That's all. Works on iOS 8.
    this worked like a charm. thank you!
    05-09-2015 12:16 PM
  18. Kaleemullah Adil's Avatar
    Thanks. This worked for me. -->Settings-->Mail,Contacts,Calender-->Off iCloud Sync(Delete all Option)-->On iCloud Sync.

    Post sync, all your iPhone contacs should be available on iCloud aswell. thanks.
    08-12-2015 12:05 AM
  19. kidclam's Avatar
    Alternatively and much quicker, I just clicked on the side tab On my Mac and highlighted the full list and just dragged into iCloud contact section, and it copied all the contacts into there. I then double checked the iCloud list to see if there are any duplicates and edited which ones I needed. It was so fast.
    luminosity6 likes this.
    09-11-2015 01:13 AM
  20. Vaudousi's Avatar
    I am a french speaking person.. Many thanks for letting me in.

    My question is in the title. I am looking for help. I use an iPhone 5S and my computers are under W10. Even after reading some suggestions from some members of this group, i still cannot display all my contacts under iCloud.

    Thanks
    12-16-2015 05:32 PM
  21. Just_Me_D's Avatar
    I am a french speaking person.. Many thanks for letting me in.

    My question is in the title. I am looking for help. I use an iPhone 5S and my computers are under W10. Even after reading some suggestions from some members of this group, i still cannot display all my contacts under iCloud.

    Thanks
    Via a computer, export your W10 contacts and then import them to iCloud. The imported contacts will sync to your iPhone, if iCloud is configured properly on the device.
    12-16-2015 06:49 PM
  22. Vaudousi's Avatar
    Sorry I was not clear. Language barrier.

    The iPhone displays 104 contacts. The title says " Groups All my contacts", But when I do a backup via iTunes, only 73 contacts are saved.

    I read all posts in this thread and tried to apply the recommended procedures, but without success.

    I do not know how the file was separated into two parts. I fear to lose some.

    The iPhone is a 5S with iOS 9.2

    The computer with iTunes is an Asus G10AC (I7 - 16 Gb - 1 Tb). OS is Windows 10.
    TKS.
    12-17-2015 02:09 PM
  23. luminosity6's Avatar
    Sorry I was not clear. Language barrier.

    The iPhone displays 104 contacts. The title says " Groups All my contacts", But when I do a backup via iTunes, only 73 contacts are saved.

    I read all posts in this thread and tried to apply the recommended procedures, but without success.

    I do not know how the file was separated into two parts. I fear to lose some.

    The iPhone is a 5S with iOS 9.2

    The computer with iTunes is an Asus G10AC (I7 - 16 Gb - 1 Tb). OS is Windows 10.
    TKS.
    Hi,

    Are you using Outlook desktop on Windows 10? If yes, and if you have both accounts set up in Outlook, you can drag the contacts into your iCloud account. I recently moved my contacts from my old email account to iCloud this way.
    01-01-2016 08:01 AM
  24. revdocajv's Avatar
    You rock, Jennnnnnn!
    I spent hours and in no time it was done..ugh
    Thank you!
    Now working on setting up apps on my iPad air
    Is there a way to automatically have them pick up the login info from iPhone?
    04-27-2016 07:30 AM

Similar Threads

  1. How to delete music and videos from iPhone
    By jaleelhamid in forum iPhone 5s
    Replies: 14
    Last Post: 04-23-2014, 09:12 AM
  2. My iPhone 5C Review
    By Darren Ingram in forum iPhone 5c
    Replies: 13
    Last Post: 12-10-2013, 11:44 PM
  3. Select Garmin iOS apps up to 50% off on Black Friday
    By iMore.com in forum iMore.com News Discussion
    Replies: 1
    Last Post: 11-27-2013, 11:59 AM
  4. multi delete contacts
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 11-26-2013, 07:28 PM
  5. Icloud
    By jaleelhamid in forum iCloud
    Replies: 1
    Last Post: 11-26-2013, 03:49 PM
LINK TO POST COPIED TO CLIPBOARD