1. iMore Question's Avatar
    Got my 5s today. Nanosim is working. The service provide shows up in the left upper corner. When I switch it on a whole lot of , I think Chinese, characters show up with one that says English UK. If you tick that, it still stays on Chinese. My home WiFi also shows up. Pleasehhelp. If you call the phone , it rings in your ear, but the phone itself does not ring. Please help
    11-11-2013 08:21 AM
  2. Just_Me_D's Avatar
    Who is your carrier? What language so you have set on the device? Do the following:

    1. Go to Settings->General->International and then select the correct language and region format.

    2. Go to Settings->General->Date & Time and then set the correct time zone.
    3. Reboot your device.
    11-11-2013 08:51 AM

Similar Threads

  1. Replies: 20
    Last Post: 12-30-2014, 02:37 AM
  2. Replies: 4
    Last Post: 11-11-2013, 11:13 AM
  3. [GUIDE] How To Turn Off Automatic App Updates In iOS 7
    By Jaguarr40 in forum Guides & How-To Articles
    Replies: 3
    Last Post: 11-11-2013, 04:26 AM