1. MGS69's Avatar
    Hi all,

    I have a problem which hovers around a number of questions here, but I don't seem to find a solution to the problem. More over I become more and more confused and find it difficult to differentiate between synced and uploaded music and where my music is stored.

    Here is my situation: I have several GB (less than 100 GB) of music on Apple lossless format on my NAS. I do not have available space on the HD of my Macbook to transfer have all my music to it.

    I have subscribed to Apple Music, and I would like to have all my music available for streaming on all my entities (Iphone, Mac, AppleTV and Ipad).

    Here is what I have done. I have imported all my music to the Apple Music via the app on my MacBook. There is no local copy and it only plays when there is access to the NAS. I have enabled Sync library and pressed Update to iCloud several times. Yes, only a fraction of the songs are uploaded to the Library (I can see those on my iPhone), but most of the music is only shown with a Cloud/Exclamation mark in the Music app on the Macbook. So, there is an error when uploading I guess.

    What to do?

    Please assist and ask more questions if above is a little unclear.

    Thank you
    Morten
    12-06-2020 05:11 AM
  2. Tartarus's Avatar
    When your NAS is online and available during the sync process, you should wait at least a few hours to days until syncing is completed.
    Don’t turn off your NAS and MacBook in iCloud hé meantime.
    Also, make sure the file format of the songs is supported by Music.

    Once the syncing is complete, you can turn off both your NAS and MacBook and still have access to your songs via Music.
    12-06-2020 05:56 AM
  3. MGS69's Avatar
    Thank you makes a lot of sense. Problem is, that I do not see any progress in the number of songs being uploaded. And I don't see the Sync dialog" in the lower let corner of the application. I have tried to press play on a single song (with exclamation mark), and it plays fine. Then, I pressed add to library and it was synced/uploaded and the exclamation mark disappeared. But all the songs that has not been actively played appears not the uploaded. E.g the song just below the one actively played, when I press Add to library it still shows an error, after it appears as have been trying to upload.
    12-06-2020 06:25 AM
  4. Tartarus's Avatar
    Thank you makes a lot of sense. Problem is, that I do not see any progress in the number of songs being uploaded. And I don't see the Sync dialog" in the lower let corner of the application. I have tried to press play on a single song (with exclamation mark), and it plays fine. Then, I pressed add to library and it was synced/uploaded and the exclamation mark disappeared. But all the songs that has not been actively played appears not the uploaded. E.g the song just below the one actively played, when I press Add to library it still shows an error, after it appears as have been trying to upload.
    Then you should select all the songs and press Add to Library.
    I’m not sure what else you could do to solve this apart from that.
    12-06-2020 08:46 AM

Similar Threads

  1. Show Apple Mag Safe Wallet Combo.
    By Hansana in forum iPhone 12
    Replies: 2
    Last Post: 12-09-2020, 10:20 PM
  2. Dutch antitrust investigation focuses in on Apple Pay
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 5
    Last Post: 12-07-2020, 10:14 AM
  3. Sing along with Stillwater & the 'Never Ending Dream' in a new Apple TV ad
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 12-05-2020, 10:00 AM
  4. Apple launches display replacement program for the iPhone 11
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 12-04-2020, 11:51 PM
  5. Lisa Jackson talks Apple's climate goals, partnership with Malala Fund
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 12-04-2020, 06:22 PM
LINK TO POST COPIED TO CLIPBOARD